1148 Werewolf - Simple Version (20 分)

1148 Werewolf - Simple Version (20 分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

2018.9月pat秋的第一题................我卡了一小时 虽然知道是暴力 可是真的是不知道怎么写........

这是看别人的代码写的

转载来自:https://blog.csdn.net/ryo_218/article/details/82560124

代码:

import java.util.Scanner;
public class PA_1148 {
	static Scanner sc = new Scanner(System.in);
	public static void main(String[] args) {
		int n ;
		n = sc.nextInt();
		int digit[] = new int [n + 1];
		for(int i = 1; i <= n; i++)
			digit[i] = sc.nextInt();
		
		for(int i = 1; i <= n; i++)
		{
			for(int j = i + 1; j <= n; j++)
			{
				//枚举i和j是狼
				int wolf = 0, man = 0;//表示说慌的数量
				for(int k = 1; k <= n; k++)
				{
					 if(k == i || k == j)//狼撒谎的话
					 {
						 if(digit[k] > 0 && digit[k] == i || digit[k] == j)
							 wolf++; //如果说这个id是人的话但是确实i或者j那么就是狼撒谎
						 else if(digit[k] < 0 && Math.abs(digit[k]) != i && Math.abs(digit[k]) != j) 
						 	wolf++; //如果说这个id是狼的话  但是却不是i或者是j  那么还是狼撒谎
					 }else //人撒谎的话
					 {
						 if(digit[k] < 0 && Math.abs(digit[k]) != i && Math.abs(digit[k]) != j)
							 man++;
						 else if(digit[k] > 0 && digit[k] == i || digit[k] == j)
							 man++;
					 }
				}
				if(wolf == 1 && man == 1)
				{
					System.out.println(i+" "+j);
					System.exit(0);
				}
			}
		}
		System.out.println("No Solution");
	}

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值