1148 Werewolf - Simple Version

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

两个狼人两个骗子,其中有一个狼人是骗子,四层for循环来枚举:

两个for循环枚举两个狼人,这样答案输出时可以保证是最小序列,然后分别考虑两个狼人各自撒谎的时候,第三层for循环枚举撒谎的人类,然后更改两个骗子的陈述,取相反数即可,第四层for循环验证这样的假设情况下所有人的陈述是否矛盾,如果不矛盾直接输出两个狼人,return 0;否则继续下一次枚举,如果所有枚举的情况都有矛盾,输出No Solution。

#include <iostream>
#include <cmath>
#include <cstring>
using namespace std;
int n;
int a[110]; //输入、真正陈述
bool flag;

int main() {
	cin >> n;
	for (int i = 1; i <= n; i++) {
		cin >> a[i];
	}
	for (int i = 1; i <= n; i++) {
		for (int j = i + 1; j <= n; j++) { //枚举狼人
			a[i] = -a[i]; //第一个狼人说谎
			for (int k = 1; k <= n; k++) { //枚举说谎的人类
				flag = 0;
				if (k != i && k != j) {
					a[k] = -a[k];
					for (int c = 1; c <= n; c++) { //验证说法是否矛盾
						if (a[c] < 0 && abs(a[c]) != i && abs(a[c]) != j) {
							flag = 1;
							break;
						}
						if (a[c] > 0 && (a[c] == i || a[c] == j)) {
							flag = 1;
							break;
						}
					}
					if (!flag) {
						cout << i << ' ' << j;
						return 0;
					}
					a[k] = -a[k];
				}
			}
			a[i] = -a[i];
			a[j] = -a[j]; //第二个狼人说谎
			for (int k = 1; k <= n; k++) { //枚举说谎的人类
				flag = 0;
				if (k != i && k != j) {
					a[k] = -a[k];
					for (int c = 1; c <= n; c++) { //验证说法是否矛盾
						if (a[c] < 0 && abs(a[c]) != i && abs(a[c]) != j) {
							flag = 1;
							break;
						}
						if (a[c] > 0 && (a[c] == i || a[c] == j)) {
							flag = 1;
							break;
						}
					}
					if (!flag) {
						cout << i << ' ' << j;
						return 0;
					}
					a[k] = -a[k];
				}
			}
			a[j] = -a[j];
		}
	}
	cout << "No Solution";
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值