1018 Public Bike Management (30 分)(Dij+DFS)

1018 Public Bike Management (30 分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

先求最短路径最小的那个,如果最短路径有多个,求能带的自行车数最少的,如果还有很多条不同的路,那么就找一个从车站带回的自行车数目最少的。带回的时候是不调整的(这边奥 ,我wa了一次 有一个25分,就是因为我以为回去的时候是会调整)

结果是带过来的是可以边调整 带回去是不会边调整边带回去的

代码:

#include<bits/stdc++.h>
using namespace std;
const int inf = 0x3f3f3f3f;
int total,sta,over,road;//总共有这个数 
int much[505];
int maze[505][505];
int vis[505],dis[505];
int totalcost = 0, nowneed = inf, nowback = 0 ;
vector<int>vec,last;
struct node
{
	vector<int>vec;
	int nowneed ,nowback;
	node(){
		nowneed = inf; //想要最少送过来的 
		nowback = inf; //想要最少往回送的 
	} 
}pro,tmp;
void DFS(int beginn, int endd,int num,int more,int less)
{
	if(num > totalcost)
		return;//这个是超过就再见把 
	if(beginn == endd)
	{
		tmp.nowneed = less;
		tmp.nowback = more;
		if(pro.nowneed > tmp.nowneed)
			pro = tmp;
		else if(pro.nowneed == tmp.nowneed)
		{
			if(pro.nowback > tmp.nowback)
				pro = tmp;
		}
		return ;	
	} 
	for(int i = 1; i <= sta; i ++)
	{
		if(vis[i] == 0 && maze[beginn][i] != inf)
		{
			vis[i] = 1;
			tmp.vec.push_back(i);
			int gg = much[i] - total / 2;//当前多余的,或者是当前缺失的。 
			int k1 = more, k2 = less;
			if(gg < 0) //表示当前缺失的
			{
				int kk = abs(gg); //表示需要拨这些过来 
				if(k1 >= kk){
					k1 = k1 - kk;
					k2 = less;
				}	
				else 
				{
					k2 = k2 + abs(k1 - abs(gg)); 
					k1 = 0;//对于的没有了
				}
			}else if(gg > 0)
				k1 += gg;
			DFS(i, endd,num + maze[beginn][i],k1, k2);
			vis[i] = 0;	
			tmp.vec.pop_back();
		}	
	}
	return ;
}
int Dij()
{
	for(int i = 0; i <= sta; i ++)
		dis[i] = maze[0][i];  
	vis[0] = 1;//标记下哈哈
	for(int i = 0; i <= sta; i++)
	{
		int maxn = inf, u = -1;
		for(int j = 0; j <= sta; j++)	
		{
			if(vis[j] == 0 && dis[j] < maxn)
			{
				maxn = dis[j];
				u = j;
			}
		}
		if(u == -1)
			break;
		vis[u] = 1;
		for(int j = 1; j <= sta; j++ )
		{
			if(vis[j] == 0 )
			{
				if(dis[u] + maze[u][j] < dis[j])
					dis[j] = dis[u] + maze[u][j];	
			}	
		}
	} 
	return dis[over];
}
int main()
{
	scanf("%d %d %d %d",&total, &sta, &over, &road); 
	for(int i = 1; i <= sta; i ++)
		scanf("%d",& much[i]); //表示的是每个站点有多少个
	for(int i = 0; i <= sta; i ++)
	{
		for(int j = 0 ; j <= sta; j ++)
			maze[i][j] = inf;
		maze[i][i] = 0;
	}
	for(int i = 1; i <= road; i ++)
	{
		int x, y , z;
		scanf("%d %d %d",&x,&y,&z);
		maze[x][y] = maze[y][x] = z;
	} 
	totalcost = Dij(); //ok这边就是求得对短路,然后现在开始。。。。嗯? 找路径 
	memset(vis,0,sizeof(vis));
	vis[0] = 1; 
	tmp.vec.push_back(0);
	DFS(0, over, 0, 0, 0);
	printf("%d %d",pro.nowneed,0); 
	for(int i = 1 ; i < pro.vec.size(); i ++)
		printf("->%d",pro.vec[i]);
	printf(" %d\n",pro.nowback);
	return 0;
} 

 

 

 


 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值