1109 Group Photo (25 分)deque<STL>

1109 Group Photo (25 分)

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

  • All the people in the rear row must be no shorter than anyone standing in the front rows;

  • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (≤10​4​​), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159

Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John

 

代码:

#include<bits/stdc++.h>
using namespace std;
struct node
{
	int hei;
	char str[10];
}s[10005];
bool cmp(node a, node b){
	if(a.hei != b.hei)
		return a.hei > b.hei;//从高到低
	else 
		return strcmp(a.str , b.str) < 0;
}

int main()
{
	int n, k ;
	scanf("%d %d", &n,&k);
	for(int i = 1; i <= n; i++)
		scanf("%s %d",s[i].str, &s[i].hei);
	sort(s + 1,s + 1 + n, cmp);
	int num = n / k;       //表示每排的人数
	int dd = num + n % k;  //表示第一排的人数。。可以考虑用deque
	deque<node>de[15];
	de[1].push_front(s[1]);//扔进去
	for(int i = 2; i <= dd; i++)
	{
		de[1].push_front(s[i]);
		++i;
		if(i <= dd)
			de[1].push_back(s[i]);
	}
	k = 2; //表示此刻是2 
	while(dd + num <= n)
	{	
		de[k].push_front(s[dd + 1]);
		for(int i = dd + 2; i <= dd + num; i++)
		{
			de[k].push_front(s[i]);
			i++;
			if(i <= dd + num)
				de[k].push_back(s[i]);
		}
		dd = dd + num; 
		k ++;
	}
	for(int i = 1; i <= k; i++)
	{
		while(de[i].empty() == 0)
		{
			node tmp = de[i].front();
			de[i].pop_front();
			printf("%s",tmp.str);
			if(de[i].empty() == 1)
				printf("\n");
			else 
				printf(" ");
			
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值