L2-008 最长对称子串 (25 分)

L2-008 最长对称子串 (25 分)

对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?,最长对称子串为s PAT&TAP s,于是你应该输出11。

输入格式:

输入在一行中给出长度不超过1000的非空字符串。

输出格式:

在一行中输出最长对称子串的长度。

输入样例:

Is PAT&TAP symmetric?

输出样例:

11

 

#include<bits/stdc++.h>
using namespace std;
const int maxn = 220020;
char beginn[maxn],endd[maxn];
int len[maxn];
int tralation()
{
	int gg = strlen(beginn);
	int now = 0;
	endd[now] = '&';
	for(int i = 0 ; i < gg; i ++)
	{
		endd[++now] = '#';
		endd[++now] = beginn[i]; 
	}
	endd[++now] = '#';
	return now;
}
int Manacher(int total)
{
	int maxn = 0;
	int mx = 0, id = 0;
	for(int i = 1; i <= total; i ++)
	{
		if(i < mx)
			len[i] = min(len[2 * id - i], mx -i);
		else 
			len[i] = 1;
		while(endd[i + len[i]] == endd[i - len[i]])
			len[i]++;
		if(i + len[i] > mx)
		{
			mx = i + len[i];
			id = i;
		}
		maxn = max(maxn,len[i]);
	}
	return maxn - 1;
}
int main(){
	scanf("%[^\n]s",beginn);
	int total = tralation();
	int ans = Manacher(total);
	cout<<ans<<endl;
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值