L3-016 二叉搜索树的结构 (30 分)

L3-016 二叉搜索树的结构 (30 分)

二叉搜索树或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值;若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值;它的左、右子树也分别为二叉搜索树。(摘自百度百科)

给定一系列互不相等的整数,将它们顺次插入一棵初始为空的二叉搜索树,然后对结果树的结构进行描述。你需要能判断给定的描述是否正确。例如将{ 2 4 1 3 0 }插入后,得到一棵二叉搜索树,则陈述句如“2是树的根”、“1和4是兄弟结点”、“3和0在同一层上”(指自顶向下的深度相同)、“2是4的双亲结点”、“3是4的左孩子”都是正确的;而“4是2的左孩子”、“1和3是兄弟结点”都是不正确的。

输入格式:

输入在第一行给出一个正整数N(≤100),随后一行给出N个互不相同的整数,数字间以空格分隔,要求将之顺次插入一棵初始为空的二叉搜索树。之后给出一个正整数M(≤100),随后M行,每行给出一句待判断的陈述句。陈述句有以下6种:

  • A is the root,即"A是树的根";
  • A and B are siblings,即"AB是兄弟结点";
  • A is the parent of B,即"AB的双亲结点";
  • A is the left child of B,即"AB的左孩子";
  • A is the right child of B,即"AB的右孩子";
  • A and B are on the same level,即"AB在同一层上"。

题目保证所有给定的整数都在整型范围内。

输出格式:

对每句陈述,如果正确则输出Yes,否则输出No,每句占一行。

输入样例:

5
2 4 1 3 0
8
2 is the root
1 and 4 are siblings
3 and 0 are on the same level
2 is the parent of 4
3 is the left child of 4
1 is the right child of 2
4 and 0 are on the same level
100 is the right child of 3

输出样例:

Yes
Yes
Yes
Yes
Yes
No
No
No

如果是26分或者28分的注意下 万一都没有啊!!!怎么整 因为用map 如果都没有不就说明说都!不存在嘛!这边没有考虑 多交了好几发才得到这个!ggggg

#include<bits/stdc++.h>
using namespace std;
struct node
{
	int data;
	struct node* left;
	struct node* right;
};
struct node* Insert(struct node* root, int x)
{
	if(root == NULL)
	{
		root = new node();
		root->data = x;
		root->left = root->right = NULL;
	}else 
	{
		if(x < root->data)
			root->left = Insert(root->left,x);
		else if(x > root->data)
			root->right = Insert(root->right,x);
	}
	return root;
}
//void Inorder(struct node* root)
//{
//	if(root)
//	{
//		Inorder(root->left);
//		printf("%d ",root->data);
//		Inorder(root->right);
//	}
//	return ;
//}
map<int,int>mp;
void GetId(struct node*root,int x)
{
	mp[root->data] = x;
	if(root->left)
		GetId(root->left,x * 2);
	if(root->right)
	 	GetId(root->right,x * 2 + 1);
	return ;
}
int main()
{
	int n,x;
	scanf("%d",&n);
	struct node* root = NULL;
	for(int i = 1; i <= n; i ++)
	{
		scanf("%d",&x);
		root = Insert(root,x);	
	}
	int t;
	scanf("%d",&t);
	GetId(root,1);
// 	map<int,int>::iterator it = mp.begin();
// 	while(it != mp.end())
// 	{
// 		cout<<it->first<<"   "<<it->second<<endl;
// 		it++;
// 	}
	
	while(t--)
	{
		int A,B;
		char str[10];
		scanf("%d",&A);
		scanf("%s",str);
		int flag;
		if(strcmp(str,"and") == 0)
		{
			scanf("%d%s%s",&B,str,str);
			if(strcmp(str,"siblings") == 0)
			{
				if(mp[A] / 2 == mp[B] / 2)
					flag = 1;
				else 
					flag = 0;
			}else 
			{
				for(int i = 0 ; i < 3; i ++)
					scanf("%s",str);
				int cnt1 = 0,cnt2 = 0;
				int g1 = mp[A];
				while(g1 != 0){
					g1 = g1 / 2;
					cnt1++;
				}
				int g2 = mp[B];
				while(g2 != 0){
					g2 = g2 / 2;
					cnt2++;
				}
				if(cnt1 == cnt2  && mp[A] != 0 && mp[B] != 0)
					flag = 1;
				else 
					flag = 0;
			}
		}else  
		{
			scanf("%s%s",str,str);//the
			if(strcmp(str,"root") == 0)
			{
				if(A == root->data)
					flag = 1;
				else 
					flag = 0;	
			}else if(strcmp(str,"parent") == 0)
			{
				scanf("%s%d",str,&B);
				if(mp[B] / 2 == mp[A])
					flag = 1;
				else 
					flag = 0;
				
			}else if(strcmp(str,"left") == 0)
			{
				scanf("%s%s%d",str,str,&B);
				if(mp[B] * 2 == mp[A])
					flag = 1;
				else 
					flag = 0;
			}else if(strcmp(str,"right") == 0)
			{
				scanf("%s%s%d",str,str,&B);
				if(mp[B] * 2 + 1 == mp[A])
					flag = 1;
				else 
					flag = 0;
			}
		}
		if(flag)printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值