Program3_V

 我现在做的是第三专题编号为1022的试题,具体内容如下所示:

Problem V

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 33   Accepted Submission(s) : 15
Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.<br><br><center><img src=../../../data/images/con211-1010-1.jpg></center> <br>For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.<br><br><br>His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . <br>Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.<br><br>Notes and Constraints<br> 0 < T <= 100<br> 0.0 <= P <= 1.0<br> 0 < N <= 100<br> 0 < Mj <= 100<br> 0.0 <= Pj <= 1.0<br> A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6

简单题意:

一个人想到银行抢钱,但又怕被抓到,所以,他就统计了各个银行的金额和被抓的概率,得出在不被抓到的条件下能偷到的最多的钱数。


解题思路:

转化为01背包问题,在01背包中,每个物品代价是每个银行的钱的数目,物品的价值是在该银行不被抓的概率,即1-被抓概率,背包容量是所有银行钱的总和,求dp[i]表示获得i的钱不被抓的最大概率,最后从大到小枚举出dp[i]>=(1-p),这个i就是答案。


编写代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;
double dp[10010];
int value[110];
double weight[110];
int nv;

void ways(int cost,double weight)
{
    for(int i=nv; i>=cost; i--)
       dp[i]=max(dp[i],dp[i-cost]*weight);
}

int main()
{
    int t;
    int nk;
    double p;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%lf%d",&p,&nk);
        nv = 0;
        for(int i=0; i<nk; i++)
        {
            scanf("%d%lf",&value[i],&weight[i]);
            weight[i] = 1-weight[i];
            nv += value[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=0; i<nk; i++)
          ways(value[i],weight[i]);
        for(int i=nv; i>=0; i--)
          if(dp[i]>=1-p)
          {
              printf("%d\n",i);
              break;
          }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值