Program4_R

 我现在做的是第四专题编号为1018的试题,具体内容如下所示:

Problem R

Time Limit : 15000/8000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 3
Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:<br>1) Extract the common characteristics from the incoming email.<br>2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.<br><br>We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:<br><br>a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so<br>relationships (other than the one between X and Y) need to be created if they are not present at the moment.<br><br>b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.<br><br>Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.<br>Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.<br>Each test case starts with two integers, N and M (1 ≤ N ≤ 10<sup>5</sup> , 1 ≤ M ≤ 10<sup>6</sup>), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.<br>Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 

Sample Output
  
  
Case #1: 3 Case #2: 2
 

简单题意:

有N 封邮,编号 0 -> N-1,  然后有两种操作,  M : 合并操作, 2 种邮件合并为一种;S  : 分离操作, 将一封邮件独立出去单独占一个集合,
最后题目要求统计集合的个数.   从这里可以很容易的看出这是一个并查集的题目, 不过按朴素方法来做的一般都会TLE


解题思路:

因为并查集是树形结构,所以无法简单的把一个节点从一棵树中删去并维护原来的信息。那这里用到的思想就是还是保持原来的树的结构不变,只是把被删掉的那个点设为虚点,并新建一个点,把原来的点映射到这个新点上,代表以后的操作都是对这个新点进行操作。这样空间开销虽然大,但还是可以解决问题的。


编写代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include<set>
using namespace std;
typedef long long LL;
typedef pair<int,int> P;
const int maxn = 2000000 + 5;
const int INF = 1000000000;

int cnt;
int fa[maxn],id[maxn];

int Find(int x)
{
    return fa[x]==x?fa[x]:fa[x]=Find(fa[x]);
}
set<int> S;

int main(){
    int n,m;
    int kase = 0;
    while(scanf("%d%d",&n,&m)){
        if(n == 0 && m == 0) break;
        kase++;
        cnt = n;
        for(int i = 0;i < maxn;i++)
            fa[i] = i;
        for(int i = 0;i < n;i++)
            id[i] = i;
        while(m--){
            char s[5];
            int a,b;
            scanf("%s",s);
            if(s[0] == 'M'){
                scanf("%d%d",&a,&b);
                int X = Find(id[a]);
                int Y = Find(id[b]);
                if(X != Y) fa[X] = Y;
            }
            else{
                scanf("%d",&a);
                id[a] = cnt++;
            }
        }
        S.clear();
        for(int i = 0;i < n;i++){
            S.insert(Find(id[i]));
        }
        printf("Case #%d: %d\n",kase,S.size());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值