地址:http://acm.hdu.edu.cn/showproblem.php?pid=4762
Cut the Cake
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 310 Accepted Submission(s): 141
Problem Description
MMM got a big big big cake, and invited all her M friends to eat the cake together. Surprisingly one of her friends HZ took some (N) strawberries which MMM likes very much to decorate the cake (of course they also eat strawberries, not just for decoration). HZ is in charge of the decoration, and he thinks that it's not a big deal that he put the strawberries on the cake randomly one by one. After that, MMM would cut the cake into M pieces of sector with equal size and shape (the last one came to the party will have no cake to eat), and choose one piece first. MMM wants to know the probability that she can get all N strawberries, can you help her? As the cake is so big, all strawberries on it could be treat as points.
Input
First line is the integer T, which means there are T cases.
For each case, two integers M, N indicate the number of her friends and the number of strawberry.
(2 < M, N <= 20, T <= 400)
For each case, two integers M, N indicate the number of her friends and the number of strawberry.
(2 < M, N <= 20, T <= 400)
Output
As the probability could be very small, you should output the probability in the form of a fraction in lowest terms. For each case, output the probability in a single line. Please see the sample for more details.
Sample Input
2 3 3 3 4
Sample Output
1/3 4/27
做法:概率公式n/m^(n-1)
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
int num[1000],a[100],g;
int gcd(int a,int b)
{
if(!b) return a;
else return gcd(b,a%b);
}
void cheng(int m) //山寨大数乘以小数
{
int a=0;
for(int i=0;i<g;i++)
{
num[i]*=m;
num[i]+=a;
a=num[i]/10000;
num[i]%=10000;
}
while(a)
{
num[g]=a%10000;
a/=10000;
g++;
}
}
int main()
{
int t,m,n,k,s;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&m,&n);
s=n;g=1;
for(int i=1;i<n;i++)
{
a[i]=m;
k=gcd(s,a[i]);
a[i]/=k;
s/=k;
}
memset(num,0,sizeof(num));
num[0]=1;
for(int i=1;i<n;i++)
cheng(a[i]);
printf("%d/%d",s,num[g-1]);
for(int i=g-2;i>=0;i--)
printf("%04d",num[i]); //输出要注意,最好用“%04d”。
printf("\n");
}
return 0;
}