hdu3652(数位DP)

地址:http://acm.hdu.edu.cn/showproblem.php?pid=3652

B-number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1744    Accepted Submission(s): 966


Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output
Print each answer in a single line.
 

Sample Input
  
  
13 100 200 1000
 

Sample Output
  
  
1 1 2 2
 

题意:求小于等于n的含有13且是13的倍数的数字的个数。

思路:数位dp,开四维数组,第一维表示位数,第二维表示开头数字,第三维表示对13余数,第四维表示是否含有13(1表示有0表示无)。然后就是纯数位dp模板。

代码:

#include<iostream>
#include<cmath>
//#include<vector>
#include<cstdio>
#include<cstring>
//#include<algorithm>
using namespace std;
//#define M 1000000007
int dp[20][20][20][2]= {0};
void getdp()  //打表
{
    int i,j,k,l,s=1;
    dp[0][0][0][0]=1;
    for(i=1; i<=10; i++)
    {
        for(j=0; j<=9; j++)
        {
            for(k=0; k<=9; k++)
            {
                for(l=0; l<13; l++)
                {
                    if(k==3&&j==1)
                        dp[i][j][(l+(j*s)%13)%13][1]+=dp[i-1][k][l][0];
                    else dp[i][j][(l+(j*s)%13)%13][0]+=dp[i-1][k][l][0];
                    dp[i][j][(l+(j*s)%13)%13][1]+=dp[i-1][k][l][1];
                }
            }
        }
        s*=10;
    }
}
int main()
{
    int m,i,j,l;
    getdp();
    while(scanf("%d",&m)>0)
    {
        int len=1,len1[20]= {0},x=1,s=m,cg=0;
        if(m%13==0) cg=1;
        while(m)
        {
            len1[len++]=m%10;
            m/=10;
            x*=10;
        }
        int ans=0,bg=0;
        for(i=len-1; i>=1; i--)
        {
            for(j=0; j<len1[i]; j++)
            {
                ans+=dp[i][j][(13-((s/x)*x)%13)%13][1];
                if(bg||(len1[i+1]==1&&j==3)) ans+=dp[i][j][(13-((s/x)*x)%13)%13][0];  //判断这位是不是13
            }
            if(len1[i]==3&&len1[i+1]==1) bg=1;  //判断是否在前面已出现13
            x/=10;
        }
        if(cg&&bg) ans++;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值