hdu4352(数位DP)

地址:http://acm.hdu.edu.cn/showproblem.php?pid=4352

XHXJ's LIS

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 670    Accepted Submission(s): 268


Problem Description
#define xhxj (Xin Hang senior sister(学姐)) 
If you do not know xhxj, then carefully reading the entire description is very important.
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.
Like many god cattles, xhxj has a legendary life: 
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year's summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world's final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world's final(there is only one team for every university to send to the world's final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo's, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don't black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。
 

Input
First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.(
0<L<=R<2 63-1 and 1<=K<=10).
 

Output
For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.
 

Sample Input
  
  
1 123 321 2
 

Sample Output
  
  
Case #1: 139
 

题意:求从L到R之间按各个位数字顺序所得的最长递增子序列长度为k的数字个数。

思路:一开始只开了一维数组,发现对于变化的情况无法处理。

           看了下别人的代码,知道了数组的开法,然后就试着写了下,发现只用二维数组就可以得出答案,于是用二维的代码交了下,超时了。

           最后改成三维数组,三维比二维好在多组数据处理可以联系起来,所以省时。

           写这题代码时我多写了个else,测试数据的答案死活运算不出,让我找了半天错误。以前因为马虎而出错的多是定义变量重复、运算符号与判断符号写混之类的,现在又多了一种。。。

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define LL __int64
LL dp[25][1<<11][11];  //三维数组
int num[25],k;
int updata(int m,int s)  //更新数字
{
    for(int i=s;i<10;i++)
        if(m&(1<<i)) return (m^(1<<i))|(1<<s);  //若存在比i大的数字
    return m|(1<<s);  //若不存在比i大的数字
}
int getnum(int m)  //这是计算递增子序列的长度
{
    int ret=0;
    for(;m;m>>=1)
        if(m&1) ret++;
    return ret;
}
LL dfs(int len,int mak,bool p)  //数位DP搜索标准写法
{
    if(len&&getnum(mak)>k) return 0;  //如果最长递增子序列的长度已经比k大了,就不用往下搜了
    if(!len) return getnum(mak)==k;
    if(!p&&~dp[len][mak][k]) return dp[len][mak][k];
    int u=p?num[len]:9;LL ans=0;
    for(int i=0;i<=u;i++)
        ans+=dfs(len-1,(mak|i)?updata(mak,i):0,p&&i==u);
    if(!p) dp[len][mak][k]=ans;
    return ans;
}
LL getans(LL m)
{
    int len=0;
    for(;m;m/=10)
        num[++len]=m%10;
    return dfs(len,0,1);
}
int main()
{
    int t,cas=1;
    memset(dp,-1,sizeof(dp));  //三维写法更新数组写在外面,二维的话要写在while里面
    scanf("%d",&t);
    while(t--)
    {
        LL l,r;
        scanf("%I64d%I64d%d",&l,&r,&k);
        printf("Case #%d: %I64d\n",cas++,getans(r)-getans(l-1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值