poj1141(区间DP)

地址:http://poj.org/problem?id=1141

Brackets Sequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23828 Accepted: 6714 Special Judge

Description

Let us define a regular brackets sequence in the following way: 

1. Empty sequence is a regular sequence. 
2. If S is a regular sequence, then (S) and [S] are both regular sequences. 
3. If A and B are regular sequences, then AB is a regular sequence. 

For example, all of the following sequences of characters are regular brackets sequences: 

(), [], (()), ([]), ()[], ()[()] 

And all of the following character sequences are not: 

(, [, ), )(, ([)], ([(] 

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]

题意:问最少添加几个括号使每个括号有可以匹配的另一半,输出修改后的串。

思路:区间DP,和另一道有点像,不过这里要输出修改的串。输出串用递归就行了。

代码:

#include<iostream>
#include<queue>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define LL __int64
#define Mod 0xfffffff
char bk[110];
struct node
{
    int ans,k;
} dp[110][110];
void pr(int a,int b)  //递归输出
{
    if(a>b) return ;
    else if(dp[a][b].ans==0)
    {
        for(int i=a; i<=b; i++)
        {
            if(bk[i]=='('||bk[i]==')') printf("()");
            if(bk[i]=='['||bk[i]==']') printf("[]");
        }
    }
    else if(dp[a][b].ans==b-a+1)
    {
        for(int i=a; i<=b; i++)
            printf("%c",bk[i]);
    }
    else if(dp[a][b].k==b)
    {
        printf("%c",bk[a]);
        pr(a+1,dp[a][b].k-1);
        printf("%c",bk[dp[a][b].k]);
    }
    else
    {
        pr(a,dp[a][b].k);
        pr(dp[a][b].k+1,b);
    }
}
int main()
{
    gets(bk);  //注意不要用while(scanf!=EOF),用scanf输入的记得在%s后加\n
    int len=strlen(bk);
    for(int i=0; i<len; i++)
        for(int j=0; j<len; j++)
            dp[i][j].ans=0;
    for(int l=1; l<len; l++)
    {
        for(int i=0; i<len-l; i++)
        {
            int j=i+l;
            for(int k=i+1; k<=j; k++)
            {
                if((bk[i]=='('&&bk[k]==')')||(bk[i]=='['&&bk[k]==']'))
                {
                    if(dp[i][j].ans<dp[i+1][k-1].ans+dp[k+1][j].ans+2)
                    {
                        dp[i][j].ans=dp[i+1][k-1].ans+dp[k+1][j].ans+2;
                        dp[i][j].k=k;
                    }
                }
                else
                {
                    if(dp[i][j].ans<dp[i][k-1].ans+dp[k][j].ans)
                    {
                        dp[i][j].ans=dp[i][k-1].ans+dp[k][j].ans;
                        dp[i][j].k=k-1;
                    }
                }
            }
        }
    }
    pr(0,len-1);
    puts("");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值