hdu1010

地址:http://acm.hdu.edu.cn/showproblem.php?pid=1010

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52134    Accepted Submission(s): 14017


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 

这题是深搜+奇偶剪枝

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
using namespace std;
int m,n,maxt,dx,dy,yes;
int map[8][8];
int dfs(int x,int y,int t)
{
	if(yes==1||t>maxt) return 0;   //当现在搜索到的步数大于最大值时,直接跳出
	if(x==dx&&y==dy)               //一旦搜到终点,不管能不能出迷宫都要结束搜索
	{
		if(t==maxt)
		{
			yes=1;
			printf("YES\n");
		}
		return 0;
	}
	if(x>0&&map[x-1][y]==0)
	{
		map[x-1][y]=-1;
		dfs(x-1,y,t+1);
		map[x-1][y]=0;
	}
	if(y>0&&map[x][y-1]==0)
	{
		map[x][y-1]=-1;
		dfs(x,y-1,t+1);
		map[x][y-1]=0;
	}
	if(x+1<m&&map[x+1][y]==0)
	{
		map[x+1][y]=-1;
		dfs(x+1,y,t+1);
		map[x+1][y]=0;
	}
	if(y+1<n&&map[x][y+1]==0)
	{
		map[x][y+1]=-1;
		dfs(x,y+1,t+1);
		map[x][y+1]=0;
	}
	return 0;
}
int main()
{
	int i,j,sx,sy,mint;
	char str[8];
	while(scanf("%d%d%d",&m,&n,&maxt)>0,m,n,maxt)
	{
		for(i=0;i<m;i++)
		{
			scanf("%s",str);
			for(j=0;j<n;j++)
			{
				if(str[j]=='X') map[i][j]=-1;
				else map[i][j]=0;
				if(str[j]=='S')
				{sx=i;sy=j;map[i][j]=-1;}     //在这里要把起点标记为走过,我因为没有标记而wa一次
				if(str[j]=='D')
				{dx=i;dy=j;}
			}
		}
		yes=0;
		mint=fabs(sx-dx)+fabs(sy-dy);   //这一步是求最小步数
		if((maxt-mint)%2==1||mint>maxt) //奇偶剪枝以及判断最小步数是否比给定步数大
		{
			printf("NO\n");
			yes=1;
		}
		else dfs(sx,sy,0);
		if(yes==0) printf("NO\n");
	}
	return 0;
}


奇偶剪枝:

现假设起点为(sx,sy),终点为(ex,ey),给定t步恰好走到终点,则t=abs(sx-ex)+abs(sy-ey)。

而非最短路的步数s可以写为s=t+x,若x为奇数,则走s步无法到达终点


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值