FatMouse's Speed-HDU-动态规划

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6929Accepted Submission(s): 3028
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input
 
 
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900

Sample Output
 
 
4 4 5 9 7



先按体重 或 速度排序。

之后就是求其中的最大单调序列的长度了,这个是个很常见的问题了。


#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
int opt[1001], trace[1001], ans[1001];
struct Node{
	int w,p,index;
};
bool cmp(const Node & a, const Node & b){
	return a.w < b.w;
}
Node mice[1001];
int main() {
	//freopen("in.txt", "r", stdin);
	int k = 0;
	while(cin >> mice[k].w >> mice[k].p){
		mice[k].index = k+1;
		k++;
	}
	memset(opt, 0 ,sizeof(opt));
	memset(trace, 0 ,sizeof(trace));
	sort(mice, mice+k, cmp);


	int tmax = 0,index;
	for(int i=1; i<k; i++){
		for(int j=0; j<i; j++){
			if(mice[i].p  < mice[j].p && mice[i].w > mice[j].w){
				if(opt[j] + 1 > opt[i]){
					opt[i] = opt[j] + 1;
//					trace[i] = mice[j].index;
					trace[i] = j;
				}
			}
		}
		if(opt[i] > tmax){
			tmax = opt[i];
			index = i;
		}

	}

	for(int i=tmax; i>=0; i--){
		ans[i] = mice[index].index;
		index = trace[index];
	}

//	for(int i=0; i<k; i++)
//		cout << opt[i] << " ";
//	cout << endl;

//	for(int i=0; i<k; i++)
//		cout << trace[i] << " ";
//	cout << endl;
	cout <<tmax+1 << endl;
	for(int i=0; i<=tmax; i++)
			cout << ans[i] << endl;

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值