FatMouse‘s Speed(LIS)

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that

W[m[1]] < W[m[2]] < … < W[m[n]]

and

S[m[1]] > S[m[2]] > … > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7

分析:

给出n个老鼠的体重w和速度s,需要我们找到n个老鼠,使得
w[id[1]]<w[id[2]]<w[id[3]]<…<w[id[n]],
s[id[1]]>s[id[2]]>s[id[3]]>…>s[id[n]]
这里的id是指这些老鼠的输入的顺序编号
首先将所有老鼠按照 s从大到小排,如果s相同,则按w从小到大排,然后求s的最长上升子序列,同时需要输出这个序列,所以用动态规划的方法求LIS。

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
#define ll long long
using namespace std;
const int N = 1e6+10,M = 2*N;
struct node
{
	int w,s,id;
}t[N];
struct nodev
{
	int num,pre;
}dp[N];
int ans[N];
bool cmp(node a,node b)
{
	if(a.s==b.s) return a.w<b.w;
	return a.s>b.s;
}
int main()
{
	int k=1;
	while(scanf("%d%d",&t[k].w,&t[k].s)!=EOF)
	{
		t[k].id=k;
		dp[k].num=1;
		dp[k].pre=k;
		k++;
	}
	k--;
	sort(t+1,t+1+k,cmp);
	int mx=0,r;
	for(int i=2;i<=k;i++)
	{
		for(int j=1;j<i;j++)
		{
			if(t[j].w<t[i].w&&t[j].s>t[i].s&&dp[i].num<dp[j].num+1)
			{
				dp[i].num=dp[j].num+1;
				dp[i].pre=j;//记录当前i之前的元素 
			}
		}
		if(mx<dp[i].num)
		{
			mx=dp[i].num;
			r=i;//记录最长序列的最后一个元素 
		} 
	}
	printf("%d\n",mx);
	for(int i=1;i<=mx;i++)
	{
		ans[i]=r;
		r=dp[r].pre;
	}
	for(int i=mx;i>=1;i--)
	{
		printf("%d\n",t[ans[i]].id);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值