hd1002A+B 不容易啊

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 75402    Accepted Submission(s): 13980

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

 

 

Sample Input

 
 
2 1 2 112233445566778899 998877665544332211

 

 

Sample Output

 
 
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

 

 

Author

Ignatius.L

 

 

 输出格式认真看清,杭电的题输出格式真让人头疼。memset的正确调用。
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
int main()
{
    char a[1001],b[1001];
    int i,j,len1,len2,t,max,p=1;
    int m[1000],n[1000];
    scanf("%d",&t);
    while(t--)
    {
        memset(m,0,sizeof(m));
      memset(n,0,sizeof(n));
        scanf("%s",a);
        scanf("%s",b);
        len1=strlen(a);
        len2=strlen(b);
        if(len1>=len2)
        max=len1;
        else
        max=len2;
        j=0;
        for(i=len1-1;i>=0;i--)
         {
             m[j++]=a[i]-'0';
         }
         j=0;
         for(i=len2-1;i>=0;i--)
         {
             n[j++]=b[i]-'0';
         }
         for(i=0;i<=max-1;i++)
         {
             m[i]+=n[i];
             if(m[i]>=10)
             {
                 if(i==max-1)
                 {
                     max++;
                 }
                 m[i]=m[i]-10;
                 m[i+1]++;
             }
         }
         printf("Case %d:/n",p++);
         printf("%s + %s = ",a,b);
         for(i=max-1;i>=0;i--)
         {
             printf("%d",m[i]);

         }
         if(t!=0)
         printf("/n/n");
    }
    printf("/n");

  return 0;

}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值