数据结构实验之链表四:有序链表的归并

原题链接

              数据结构实验之链表四:有序链表的归并
          Time Limit: 1000MS Memory Limit: 65536KB

Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Example Input

6 5
1 23 26 45 66 99
14 21 28 50 100

Example Output

1 14 21 23 26 28 45 50 66 99 100

Hint
不得使用数组!
Author

算法是不分语言 类型的 思路就是类比的数组
首先按顺序建立两个链表
然后 从第一个元素开始比较元素的大小
吧小的接在立链表后面
如果任何一个结束那么如果另一个链还有元素直接接过来即可

#include <stdio.h>
#include <string.h>
#include  <stdlib.h>
struct node/// 链表的节点
{
    int data;
    struct node *next;
};
struct node * creat(int n)/// 顺序建链表
{
    struct node *head,*p,*q;
    head=(struct node *)malloc(sizeof(struct node ));/// 位头节点分配内存
    head->next=NULL;
    q=head;
    while(n--)
    {
        p=(struct node *)malloc(sizeof(struct node ));
        scanf("%d",&p->data);
        p->next=NULL;
        q->next=p;
        q=p;/// 更行数据
    }
    return head;
};
void output(struct node *head)
{
    struct node *p=head->next;
    while(p)
    {
        printf("%d%c",p->data,p->next==NULL?'\n':' ');
        p=p->next;
    }
}
struct node *change(struct node *head1,struct node *head2)/// 按正序归并链表
{
    struct node *p,*q,*tail;
    p=head1->next;///  用 p q 来储存两个链表的节点
    q=head2->next;
    head1->next=NULL;///新链表的节点
    tail=head1;
    free(head2);/// head2直接释放掉
    while(p && q)/// 循环遍历连个链表一直到 其中一个结束
    {
        if(p->data < q->data)/// 判断两个节点的大小
        {
            tail->next=p;
            tail=p;
            p=p->next;/// p节点后移
            tail->next=NULL;
        }
        else
        {
            tail->next=q;
            tail=q;
            q=q->next;
            tail->next=NULL;
        }
    }
    /**循环结束直接把后面的接在后面***/
    if(p) ///p 还没结束
    {
        tail->next=p;
    }
    else tail->next=q;
    return head1;

};
int main()
{
    struct node *head1,*head2;/// 建立两个头结点
    int m,n;
    scanf("%d%d",&m,&n);
    head1=creat(m);/// 建立两个链表
    head2=creat(n);
    head1=change(head1,head2);///单链表的归并
    output(head1);/// 遍历链表
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值