数据结构实验之排序八:快速排序

点击获取原题链接

                         数据结构实验之排序八:快速排序
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
给定N(N≤10^5)个整数,要求用快速排序对数据进行升序排列,注意不得使用STL。

Input
 连续输入多组数据,每组输入数据第一行给出正整数N(≤10^5),随后给出N个整数,数字间以空格分隔。
Output
 输出排序后的结果,数字间以一个空格间隔,行末不得有多余空格。
Example Input

8
49 38 65 97 76 13 27 49

Example Output

13 27 38 49 49 65 76 97

Hint

Author
#include <bits/stdc++.h>
using namespace std;
int a[100000+20];
void sort(int left,int right)///手写快拍
{
    if(left>=right)return;
    int i=left,j=right;
    int x=a[left];
    while(i<j)
    {
       while(i<j && a[j]>=x)j--;
       a[i]=a[j];
       while(i<j && a[i]<=x)i++;
       a[j]=a[i];
    }
    a[i]=x;
    sort(left,i-1);///递归排序左边
    sort(i+1,right);
}
int main()
{
     int n;
    while( cin>>n)
    {
         for(int i=0;i<n;i++)
     {
         cin>>a[i];
     }
     sort(0,n-1);
     for(int i=0;i<n;i++)
     {
         cout<<a[i];
         if(i==n-1)
         {
             cout<<endl;
         }
         else cout<<' ';
     }
    }

    return 0;
}


/***************************************************
User name: 
Result: Accepted
Take time: 0ms
Take Memory: 172KB
Submit time: 2017-03-08 19:46:24
****************************************************/
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值