HDU1059(多重背包,二进制优化)

题目

http://acm.hdu.edu.cn/showproblem.php?pid=1059

  • Problem Description
    Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
    Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

  • Input
    Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.

    The last line of the input file will be “0 0 0 0 0 0”; do not process this line.

  • Output
    For each colletcion, output "Collection #k:’’, where k is the number of the test case, and then either "Can be divided.’’ or “Can’t be divided.”.

    Output a blank line after each test case.

  • Sample Input
    1 0 1 2 0 0
    1 0 0 0 1 1
    0 0 0 0 0 0

  • Sample Output
    Collection #1:
    Can’t be divided.

    Collection #2:
    Can be divided.

题意

判断能否将物品价值分成相等的两份

思路

每种物品有多件,需要刚好装到总价值的一半,多重背包问题
但是物品数量很多,无法常规变成01背包,需要进行状态压缩

二进制优化

把一个数字z分成20+21+22+…+2x+y,即20+21+22+…+2x+y=z,则选取适当的左边这些数20,21,22…2x,y,即可组成 0~z 中的任何一个数,而不用每次都+1来到达需要的数

代码

#include<cstring>
#include<iostream>
using namespace std;

int a[7];
int val[120+10];
int dp[420000+100];

int main() {
    int cases=0;
    int sum;
    while(cin>>a[1]>>a[2]>>a[3]>>a[4]>>a[5]>>a[6] and (sum=a[1]*1+a[2]*2+a[3]*3+a[4]*4+a[5]*5+a[6]*6)) {
    	++cases;
        cout << "Collection #"<<cases<<":"<<endl;

        if(sum%2) { //总额为奇数
            cout << "Can't be divided."<<endl<<endl;
            continue;
        }

        int k=1;//二进制优化
        for(int i=1,t=1; i<=6; ++i,t=1) {
            for(; a[i]-t>0; t*=2) {//1,2,4...
                val[k++] = i*t;
                a[i]-=t;
            }
            if(a[i]>0) {//剩余的
                val[k++] = a[i]*i;
            }
        }

        memset(dp,0,sizeof(dp));//01背包
        for(int i=1; i<k; ++i)
            for (int j=sum/2; j>=val[i]; j--)
                dp[j]=max(dp[j],dp[j-val[i]]+val[i]);

        if(dp[sum/2]==sum/2)// dp[sum/2]能否放满
            cout <<"Can be divided."<<endl<<endl;
        else cout << "Can't be divided."<<endl<<endl;
    }
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值