Description
速算24点相信绝大多数人都玩过。就是随机给你四张牌,包括A(1),2,3,4,5,6,7,8,9,10,J(11),Q(12),K(13)。要求只用’+’,’-‘,’*’,’/’运算符以及括号改变运算顺序,使得最终运算结果为24(每个数必须且仅能用一次)。游戏很简单,但遇到无解的情况往往让人很郁闷。你的任务就是针对每一组随机产生的四张牌,判断是否有解。我们另外规定,整个计算过程中都不能出现小数。
Input
每组输入数据占一行,给定四张牌。
Output
每一组输入数据对应一行输出。如果有解则输出”Yes”,无解则输出”No”。
Sample Input
A 2 3 6
3 3 8 8
Sample Output
Yes
No
本题的意思是取4个整数,范围是1到13,在中间加入加减乘除四种符号,可以使用括号改变运算顺序,能否得到24。
本题的解题思路是使用深度搜索,枚举每种可能的组合情况,由于正负数的关系会得到24或-24,这两种情况都满足条件。
#include <iostream>
#include <string>
#include <algorithm>
#include <stdio.h>w
#include <cmath>
#include <string.h>
using namespace std;
int a[6];
//转换函数
int charToint(char *c)
{
int integer;
if(c[0] == 'A')
integer = 1;
else if(c[0] == 'J')
integer = 11;
else if(c[0] == 'Q')
integer = 12;
else if(c[0] == 'K')
integer = 13;
else if(c[0] == '1')
integer = 10;
else
integer = c[0] - '0';
return integer;
}
//深度搜索每一种可能
bool dfs(int x)
{
if(x == 3)
{
if(24 - a[x] == 0 || 24 + a[x] == 0)
return true;
return false;
}
//枚举每种可能的情况
for(int i = x; i < 4; i++)
for(int j = i+1; j < 4; j++)
{
cout << i << " " << j << endl;
int le = a[i], ri = a[j];
//第i个已经使用过,用于保存上一个a[x]的值
a[i] = a[x];
//使用第j个保存i个和j个数字加减乘除各种情况的值
//本次循环的a[x]在上一个a[x]的下一个数字
a[j] = le + ri;
if(dfs(x+1))
return true;
a[j] = le - ri;
if(dfs(x+1))
return true;
a[j] = le * ri;
if(dfs(x+1))
return true;
a[j] = ri - le;
if(dfs(x+1))
return true;
if(le != 0)
{
if(ri % le == 0)
{
a[j] = ri / le;
if(dfs(x+1))
return true;
}
}
if(ri != 0)
{
if(le % ri == 0)
{
a[j] = le / ri;
if(dfs(x+1))
return true;
}
}
a[i] = le;
a[j] = ri;
}
return false;
}
int main()
{
//freopen("in.txt","r",stdin);
memset(a, 0, sizeof(a));
char ac[2],bc[2],cc[2],dc[2];
while(scanf("%s%s%s%s",&ac,&bc,&cc,&dc) != EOF)
{
a[0] = charToint(ac);
a[1] = charToint(bc);
a[2] = charToint(cc);
a[3] = charToint(dc);
if(!dfs(0))
printf("%s\n", "No");
else
printf("%s\n", "Yes");
}
return 0;
}