Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.
nput Specification:
Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.
Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.
Sample Input:20 9 24 10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2 00 4 01 02 03 04 02 1 05 04 2 06 07 03 3 11 12 13 06 1 09 07 2 08 10 16 1 15 13 3 14 16 17 17 2 18 19Sample Output:
10 5 2 7 10 4 10 10 3 3 6 2 10 3 3 6 2
代码如下:
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<iterator>
using namespace std;
int pnt[200] = { -1 };
int wet[200];
int nonleaf[200];
bool cmp(const vector<int>& lhs, const vector<int>& rhs)
{
vector<int>::const_reverse_iterator rit1, rit2;
rit1 = lhs.rbegin();
rit2 = rhs.rbegin();
while (rit1 != lhs.rend() && rit2 != rhs.rend())
{
if (*rit1 > *rit2)
{
return true;
}
else if (*rit1 < *rit2)
{
return false;
}
rit1++;
rit2++;
}
if (rit1 == lhs.rend())
{
return false;
}
else
return true;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("D:\\in.txt", "r", stdin);
freopen("D:\\out.txt", "w", stdout);
#endif
fill(nonleaf, nonleaf + 200, 0);
int N(0), M(0), S(0);
cin >> N >> M >> S;
int t(0);
for (int i = 0; i < N; i++)
{
cin >> wet[i];
}
for (int i = 0; i < M; i++)
{
int parent, cnt, node;
cin >> parent >> cnt;
nonleaf[parent] = 1;
while (cnt--)
{
cin >> node;
pnt[node] = parent;
}
}
vector<vector<int> > paths;
for (int i = 0; i < N; i++)
{
if (nonleaf[i])
continue;
vector<int> path;
path.push_back(wet[i]);
int sum = wet[i];
int parent = pnt[i];
while (parent != -1)//这种思路要理解!
{
path.push_back(wet[parent]);
sum += wet[parent];
if (sum > S)
break;
parent = pnt[parent];
}
if (sum == S)
paths.push_back(path);
}
sort(paths.begin(), paths.end(), cmp);
vector<vector<int> >::iterator it;
for (it = paths.begin(); it != paths.end(); it++)
{
vector<int>::reverse_iterator rit=it->rbegin();
cout << *rit;
while (++rit != it->rend())
cout << " " << *rit;
cout << endl;
}
return 0;
}