hdu 1711 Number Sequence

Number Sequence

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
 

#include <iostream>  
#include <cstdio>  
//#include <fstream>
//#include <cstdlib>
using namespace std;  

const int NM=1000005;  
int a[NM],b[10005],ne[10005],x,y; 
//x y分别代表原来字符串和给出的模板字数串的长度
//NM代表原来字符串的最大长度
//a[NM],b[10005]分别存储原来的字符串和模板字符串

void get_neval()  
{  
	int i,j;
	j=0;
	for (i=2;i<=y;i++)
	{
		if(b[j+1]==b[i])
		{
		j++;
		ne[i]=j;
		}
		if (j>0&&b[j+1]!=b[i])
			break;
	}
}  

int KMP()  
{  
	int num=0;
	for (int i=1;i<=x;i++)
	{
		if(num==y)
		{
			return i-y+1;
			break;
		}
		if(a[i]==b[i])
			num++;
		if(a[i]!=b[i]&&num>0)
			num=0;
	}
	return -1;  
}  

int main()  
{  
	int i,T;  
	scanf("%d",&T);
	while(T--)  
	{  
		scanf("%d %d",&x,&y);
		for(i=1;i<=x;i++)  
			scanf("%d",&a[i]);
		for(i=1;i<=y;i++)  
			/*cin>>b[i];*/
			scanf("%d",&b[i]);
		if(x<y)   
		{  
			printf("-1\n");  
			continue;  
		}  
		get_neval();  
		printf("%d\n",KMP());  
	}  
	//system("pause");
	return 0;  
}  



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值