hdu 1425 sort

roblem Description

给你n个整数,请按从大到小的顺序输出其中前m大的数。
 

Input
每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。
 

Output
对每组测试数据按从大到小的顺序输出前m大的数。
 

Sample Input
  
  
5 3 3 -35 92 213 -644
 

Sample Output
 
 
213 92 3



#include<iostream>
#include <cstdlib>
#include <fstream>
using namespace std;
const int MAXN=1000005;
int hash1[MAXN];
int main()
{
	ifstream cin("aaa.txt");
	int n,m,num;
	int i,j;
	memset(hash1, 0, sizeof(hash1));
	cin>>n>>m;
	while(n--)
	{
		cin>>num;
		hash1[num+500000]++;
	}
	for (i=MAXN;i>=0&&m;i--)
	{
		//if (hash1[i]&&m)
		if (hash1[i])
		{
			for (j=0;j<hash1[i]&&m;j++)
			{
				m--;
				cout<<(i-500000);
				if (m>0)
				{
					cout<<" ";
				}
			}

		}
	}
	cout<<endl;
	system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值