Catch That Cow
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers:
N and
K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
思想:这个用的是广度搜索。有加一,减一,乘二,三种操作。就让原来的数进行这三种操作,得到的数再进行这三种操作,一直这样下去。就好似水纹最早扩散到岸边的一定是用时最少的 ,如果再标记了那些是已验证的,就有哦能省下好多资源。
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
int n,k;
int vis[100005];
int dis[100005];//
int bfs()
{
queue<int>q;
q.push(n);
memset(vis,0,sizeof(vis));
int m,t;
vis[n]=1;
dis[n]=0;
while(!q.empty())
{
m=q.front();
q.pop();
if(m==k)
{
return dis[m];
}
t=m*2;
if(t<=100000&&t>0&&!vis[t])
{
vis[t]=1;
dis[t]=dis[m]+1;
q.push(t);
}
t=m+1;
if(t<=100000&&t>=0&&!vis[t])
{
vis[t]=1;
dis[t]=dis[m]+1;
q.push(t);
}
t=m-1;
if(t<=100000&&t>=0&&!vis[t])
{
vis[t]=1;
dis[t]=dis[m]+1;
q.push(t);
}
}
return -1;
}
int main()
{
while(~scanf("%d%d",&n,&k))
{
cout<<bfs()<<endl;
}
return 0;
}
#include<cstring>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
int n,k;
int vis[100005];
int dis[100005];//
int bfs()
{
queue<int>q;
q.push(n);
memset(vis,0,sizeof(vis));
int m,t;
vis[n]=1;
dis[n]=0;
while(!q.empty())
{
m=q.front();
q.pop();
if(m==k)
{
return dis[m];
}
t=m*2;
if(t<=100000&&t>0&&!vis[t])
{
vis[t]=1;
dis[t]=dis[m]+1;
q.push(t);
}
t=m+1;
if(t<=100000&&t>=0&&!vis[t])
{
vis[t]=1;
dis[t]=dis[m]+1;
q.push(t);
}
t=m-1;
if(t<=100000&&t>=0&&!vis[t])
{
vis[t]=1;
dis[t]=dis[m]+1;
q.push(t);
}
}
return -1;
}
int main()
{
while(~scanf("%d%d",&n,&k))
{
cout<<bfs()<<endl;
}
return 0;
}