PKU-1159 Palindrome (最长公共子序列LCS)

原题链接 http://poj.org/problem?id=1159
Palindrome

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left.  You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

 

 Source Code

/*
  最长公共子序列
  DP[i, j] = 0  if i == 0 or j == 0;
  DP[i, j] = DP[i - 1][j - 1] + 1;  if ch1[i] == ch2[j]
  DP[i, j] = max(DP[i - 1][j], DP[i][j - 1]);  if ch1[i] != ch2[j]

  滚动数组:
  dp[i][j]的值只依赖于dp[i - 1][j], dp[i][j - 1], dp[i - 1][j - 1];
  dp[i%2][j]=max(dp[(i-1)%2][j], dp[i%2][j-1]);
  注意上面的取余运算,重复利用这2行数组,数组好象在“滚动”一样,所以叫滚动数组
*/

#include <iostream>
using namespace std;

#define Max 5002
#define max(a, b) (((a) > (b)) ? (a) : (b))

int main() {
	char input[Max], reversal[Max];
	int DP[2][Max];
	int i, j, len;

	while (scanf("%d", &len) !=EOF) {
		scanf("%s", input);
		for(i = 0; i < len; i++) {
			reversal[i] = input[len - 1 - i];
		}

		memset(DP, 0, sizeof(DP));

		for (i = 1; i <= len; i++) {
			for (j = 1; j <= len; j++) {
				if (input[i - 1] == reversal[j - 1]) {
					DP[i % 2][j] = DP[(i - 1) % 2][j - 1] + 1;
				} else {
                    DP[i % 2][j] = max(DP[(i - 1) % 2][j], DP[i % 2][j - 1]);
				}
			}
		}
		printf ("%d\n", len - DP[len % 2][len]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值