PKU-1503 Integer Inquiry(模拟大数相加)

原题地址 http://poj.org/problem?id=1503

Integer Inquiry

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

Source Code

/*类型:高精度加法 

总结几个较舒服的做法:

1。输入字符串,在转换成整数的同时把串反转, 这样便于计算。

如输入:1234

存储:a[0]=4, a[1]=3, .....

2。把字符串长度存在首个元素里,如a[0]。

3。从MAX递减寻找非0数,开始输出,不用记录结果长度*/

#include<iostream>
using namespace std;

#define Max 105
char str[Max];
int num[Max][Max];

int main()
{
	   int n,e,carry,i,j,count=0;
		e=0;
		memset(num,0,sizeof(num));
		while(scanf("%s",str)&&!(str[0]=='0'&&str[1]=='\0'))
		{
			num[e][0]=strlen(str);         //保存长度
			for(i=1;i<=num[e][0];i++)
				num[e][i]=str[num[e][0]-i]-'0';      //输入字符串,在转换成整数的同时把串反转
			e++;
		}
        for(i=1;i<e;i++)
		{
			carry=0;               //进位每两个数相加清零
            for(j=1;j<=Max-2;j++)
			{
				num[0][j]+=carry+num[i][j];
				carry=num[0][j]/10;
				num[0][j]%=10;
			}
		}                         //每位相加,对10取余,CARRY更新
		i=Max-1;
		while(num[0][i]==0)
			i--;
		if(i==0)
			printf("0");          //如果结果是0
		else
		{
		  for(;i>=1;i--)
			printf("%d",num[0][i]);
		}
		printf("\n");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值