hdu1015--Safecracker(dfs)

8 篇文章 0 订阅
1 篇文章 0 订阅

Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9573    Accepted Submission(s): 4876


Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
 

Sample Input
  
  
1 ABCDEFGHIJKL 11700519 ZAYEXIWOVU 3072997 SOUGHT 1234567 THEQUICKFROG 0 END
 

Sample Output
  
  
LKEBA YOXUZ GHOST no solution
这题题意是从一个字符串中找一个按最大字典序排列的个5个字符的字符串使得对应下标满足 v - w^2 + x^3 - y^4 + z^5 = target.
首先,最简单的思路是五重for循环,纯暴力代码,事实上,我测试了下,这种方法在时间效率上最高.
但是,这样这题就没有思维价值了,我想该题主要是想考察对于搜索这种算法思想的理解.
下面用dfs写这个代码:
<pre name="code" class="cpp">#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
#include <math.h>

using namespace std;

int len,cnt,target,visit[13];
char s[13],s1[13];
bool cmp(int a,int b)
{
    if(a>b) return true;
    return false;
}
int dfs(char s[],int len,int step,long long sum,int i)
{
    long long x,sum1,sum2;
    if(sum==target&&step==6) return 1;
    if(step>6) return 0;
    for(;i<len;i++)
    {
        sum1=sum;
        if(!visit[i])
        {
            visit[i]=1;
            x=s[i]-'A'+1;
            if(step%2==1) sum1+=pow(x,step);
            else sum1-=pow(x,step);
            s1[cnt++]=s[i];
            if(dfs(s,len,step+1,sum1,0)) return 1;
            s1[cnt--]=0;
            visit[i]=0;
        }
    }
        return 0;
    }
    int main()
    {

        while(~scanf("%d %s",&target,s))
        {
            if(strcmp(s,"END")==0&&target==0) break;
            len=strlen(s);
            cnt=0;
            memset(visit,0,sizeof(visit));
            sort(s,s+len,cmp);
            if(dfs(s,len,1,0,0)) printf("%s\n",s1);
            else printf("no solution\n");
        }
        return 0;
    }
133301342015-04-03 12:41:40Accepted1015187MS1812K1403 BG++gklzc0608
这是在oj上提交的结果,但是我在网上搜了份题解交上去时,发现他们的时间只有15MS,比我快了十多倍,然后突然想起来pow函数的开销比较大.
于是进行了一次改动:
<pre name="code" class="cpp">#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
#include <math.h>

using namespace std;

int len,cnt,target,visit[13];
char s[13],s1[13];
bool cmp(int a,int b)
{
    if(a>b) return true;
    return false;
}
int dfs(char s[],int len,int step,long long sum,int i)
{
    long long x,sum1,sum2;
    if(sum==target&&step==6) return 1;
    if(step>6) return 0;
    for(;i<len;i++)
    {
        sum1=sum;
        sum2=-1;
        if(!visit[i])
        {
            visit[i]=1;
            x=-(s[i]-'A'+1);
            for(int j=0;j<step;j++)
                sum2*=x;
                sum1+=sum2;
            s1[cnt++]=s[i];
            if(dfs(s,len,step+1,sum1,0)) return 1;
            s1[cnt--]=0;
            visit[i]=0;
        }
    }
        return 0;
    }
    int main()
    {

        while(~scanf("%d %s",&target,s))
        {
            if(strcmp(s,"END")==0&&target==0) break;
            len=strlen(s);
            cnt=0;
            memset(visit,0,sizeof(visit));
            sort(s,s+len,cmp);
            if(dfs(s,len,1,0,0)) printf("%s\n",s1);
            else printf("no solution\n");
        }
        return 0;
    }
133301462015-04-03 12:46:05Accepted101578MS1816K1315 BG++gklzc0608
修改后时间大大减少,但还是没有达到最少的时间开销.然后发现在判断终止时,我多进行了一次不必要的递归.
 
 
再次优化:<pre name="code" class="cpp">#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
#include <math.h>

using namespace std;

int len,cnt,target,visit[13];
char s[13],s1[13];
bool cmp(int a,int b)
{
    if(a>b) return true;
    return false;
}
int dfs(char s[],int len,int step,long long sum,int i)
{
    long long x,sum1,sum2;
    if(step==6)
    {
        if(sum==target)
        return 1;
        return 0;
    }
    for(;i<len;i++)
    {
        sum1=sum;
        sum2=-1;
        if(!visit[i])
        {
            visit[i]=1;
            x=-(s[i]-'A'+1);
            for(int j=0;j<step;j++)
                sum2*=x;
                sum1+=sum2;
            s1[cnt++]=s[i];
            if(dfs(s,len,step+1,sum1,0)) return 1;
            s1[cnt--]=0;
            visit[i]=0;
        }
    }
        return 0;
    }
    int main()
    {

        while(~scanf("%d %s",&target,s))
        {
            if(strcmp(s,"END")==0&&target==0) break;
            len=strlen(s);
            cnt=0;
            memset(visit,0,sizeof(visit));
            sort(s,s+len,cmp);
            if(dfs(s,len,1,0,0)) printf("%s\n",s1);
            else printf("no solution\n");
        }
        return 0;
    }

133301592015-04-03 12:49:47Accepted101515MS1816K1245 BG++gklzc0608
终于优化到了自己想要的结果.
 
 
如果有什么问题,欢迎大家留言指教.



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值