1148 Werewolf - Simple Version (20 分)

1148 Werewolf - Simple Version (20 分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

player #1 said: “Player #2 is a werewolf.”;

player #2 said: “Player #3 is a human.”;

player #3 said: “Player #4 is a werewolf.”;

player #4 said: “Player #5 is a human.”; and

player #5 said: “Player #4 is a human.”.

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

思路:

根据题设条件推断:

1.有两只狼,其余全为人类;

2.有两个说谎的玩家,其中一个为狼,另外一个为人类;

因此,可以枚举两只狼和另外一个说谎者,每次将两个说谎玩家说的话取反,这样所有的玩家说的都是真话,然后对这n个玩家的话进行推理,如果与“事实”矛盾,则当前假设不成立

#include <bits/stdc++.h>
using namespace std;
int A[128];
bool help(int i, int j, int lier, int n){
    for(int k = 1; k <= n; ++k){
        if(k == i || k == j) continue;
        A[lier] = -A[lier]; A[k] = -A[k];//说谎玩家取反
        vector<int> v(n + 1);//v中的取值为0(未进行推理),1(人类),-1(狼)
        v[i] = v[j] = -1;//i, j为两只狼
        bool tag = 1;
        for(int l = 1; l <= n; ++l){
            int w = abs(A[l]), val = A[l] / w;
            if(v[w] * val < 0){//与事实矛盾
                tag = 0;
                break;
            }
            v[w] = val;
        }
        int count = 0;
        for(int l = 1; l <= n; ++l) if(v[l] == -1) ++count;//有且只有两只狼
        if(tag && count == 2) return true;
        A[lier] = -A[lier]; A[k] = -A[k];
    }
    return false;
}
void WerewolfSol(int n){
    for(int i = 1; i <= n - 1; ++i){
        for(int j = i + 1; j <= n; ++j){
            if(help(i, j, i, n) || help(i, j, j, n)){
                printf("%d %d\n", i, j);
                return;
            }
        }
    }
    printf("No Solution\n");
}
int main()
{
    int n;
    scanf("%d", &n);
    for(int i = 1; i <= n; ++i){
        scanf("%d", A + i);
    }
    WerewolfSol(n);
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值