HDU 1069 Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12708    Accepted Submission(s): 6658


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342

大致题意就是为了测试猴子的智商,给出一些箱子,箱子的长宽高是给定的,每种箱子都有无限多个,现在问猴子最高能摆多高。

要求:上面的箱子的长和宽一定要比下面的箱子小(高没有要求),这样猴子才能上去,箱子怎么放置都可以,长可以当做宽,宽也可以作为高,只要满足题意就行。

思路:把给出的箱子规格可能产生的每一种情况存进一个结构体中,对结构体中的长宽都按从大到小排序,找到最高的就行了,其实就是最长递减子序列的变形。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

struct node
{
    int l,w,h;
} qq[110];
bool cmp(node A,node B)
{
    if(A.l!=B.l)
        return A.l>B.l;//长宽高都按照从大到小排序
    else
    {
        if(A.w!=B.w)
            return A.w>B.w;
        else
            return A.h>B.h;
    }
}
int main()
{
    int dp[110],d[5],i,j,n,cas=1;
    while(~scanf("%d",&n)&&n)
    {
        int k=0;
        for(i=0; i<n; i++)
        {
            scanf("%d%d%d",&d[0],&d[1],&d[2]);
            sort(d,d+3);//将d【0】,d【1】,d【2】按从小到大排序
            qq[k].l=d[1];//保证每次的长都要大于宽(或者每次的宽都大于长也可以)
            qq[k].w=d[0];
            qq[k++].h=d[2];//保证d【0】,d【1】,d【2】都当一次高
            qq[k].l=d[2];
            qq[k].w=d[1];
            qq[k++].h=d[0];
            qq[k].l=d[2];
            qq[k].w=d[0];
            qq[k++].h=d[1];
        }
        sort(qq,qq+k,cmp);
        for(i=0; i<k; i++)
            dp[i]=qq[i].h;
        for(i=1; i<k; i++)//接下来的两层for循环与单调递增最长子序列相似。可参考博客之动归NYOJ 17
        {
            for(j=0; j<i; j++)
            {
                if(qq[i].l<qq[j].l&&qq[i].w<qq[j].w&&dp[i]<dp[j]+qq[i].h)
                    dp[i]=dp[j]+qq[i].h;
            }
        }
//        int maxx=0;
//        for(i=0; i<k; i++)
//            if(maxx<dp[i])
//                maxx=dp[i];//这四行代码就是为了求出dp的最大值,可以直接在输出时用c++里的函数<span style="font-family: Arial;">*max_element 来求最大值</span>
        printf("Case %d: maximum height = %d\n",cas++,*max_element(dp,dp+k));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值