poj1979


Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 23928 Accepted: 12935

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
在一个空房间李,只能走黑色的砖,不能走红色的砖,走到无路可走就结束,不能重复走。

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
代码:
#include<stdio.h>
char a[100][100];
int map[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
int n, m;
int num;
void dfs(int x,int y)
{
    num ++;
    int xx, yy, k;
    a[x][y] = '#';//把走过的路径堵死,不能返回。
    for(k = 0; k < 4; k ++)
    {
        xx = x + map[k][0];
        yy = y + map[k][1];
        if(xx >= 0 && xx < m && yy >= 0 && yy < n && a[xx][yy] == '.')
        {
            dfs(xx,yy);
        }
    }
}
int main()
{
    int i, j, si, sj;
    while(scanf("%d%d",&n,&m) != EOF)
    {
        if(n == 0 && m == 0)
            break;
        for(i = 0; i < m; i ++)
        {
            for(j = 0; j < n; j ++)
            {
                scanf(" %c",&a[i][j]);
                if(a[i][j] == '@') //从@点开始走。
                {
                    si = i;//@点的坐标。
                    sj = j;
                }
            }
        }
        num = 0;
        dfs(si,sj);
        printf("%d\n",num);
    }
    return 0;
}


看了几遍题目,也没偶看懂,最后问了一下同学才知道题目的意思。才开始学习DFS,用晕的不是很熟练,参考着同学的代码才写出来的。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值