L2-012 关于堆的判断 (25 分)

L2-012 关于堆的判断 (25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。
输入格式:
每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:
对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

AC代码

#include<bits/stdc++.h>
#define Inf 0x3f3f3f
const int N = 1005;
using namespace std;
int n, m, cnt, no;
int ans[N];
map<int, int> p;

void create(int x){//堆的建立
	ans[++cnt] = x;
	int t = cnt;
	while(t>1 && ans[t/2]>ans[t]){
		swap(ans[t/2], ans[t]);
		t/=2;
	}
	ans[t] = x;
}
int main(){
	cin >> n >> m;
	for(int i = 1; i<= n; i ++){
		cin >> no;
		create(no);
	}
	for(int i = 1; i <= n; i ++)//记录堆下标
		p[ans[i]] = i;
	while(m--){
		string str;
		int x, y;
		cin >> x >> str;
		if(str[0]=='a'){ //兄弟节点判断 x and y are siblings
			cin >> y >> str >> str;
			if(p[x]/2==p[y]/2)
				cout << "T" << endl;
			else
				cout << "F" << endl;
		}else{
			cin >> str >> str;
			if(str[0] == 'c'){ //子节点判断: x is a child of y
				cin >> str >> y;
				if(p[x]/2==p[y])
					cout << "T" << endl;
				else
					cout << "F" << endl;
			}else if(str[0]=='r'){//根节点判断: x is the root
				if(p[x]==1)
					cout << "T" << endl;
				else
					cout << "F" << endl;
			}else if(str[0]=='p'){//父节点判断: x is the parent of y
				cin >> str >> y;
				if(p[x]==p[y]/2)
				    cout << "T" << endl;
				else
					cout << "F" << endl;
			}
		}
	}
	
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值