L2-012 关于堆的判断 (25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

思路:边输入边键堆,输入可以逐个输入,不用再把字符串的数字变成整型。

程序: 

#include <cstdio>
#include <map>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
int a[1005],cnt = 0;
// void DownAjust(int low,int high)
// {
// 	int i = low;
// 	int j = 2 * i;
// 	while(j <= high)
// 	{
// 		if(2*i+1 <= high && a[2*i+1] < a[j])
// 			j = 2 * i + 1;
// 		if(a[j] > a[i])
// 			break;
// 		swap(a[i],a[j]);
// 		i = j;
// 		j = 2 * i + 1;
// 	}
// }
void buildHeap(int data)
{
	a[++cnt] = data;
	int t = cnt;
 	while(t > 1 && a[t/2] > a[t])
	{
		swap(a[t],a[t/2]);
		t /= 2;
	}
}
int main()
{
	int n,m;
	map<int,int> mp;
	scanf("%d%d",&n,&m);
	for(int i = 1; i <= n; i++)
	{
		int data;
		scanf("%d",&data);
		buildHeap(data);
	}
	for(int i = 1; i <= n; i++)
		mp[a[i]] = i;
	string s;
	for(int i = 0; i < m; i++)
	{
		int num1,num2;
		cin >> num1;
		cin >> s;
		if(s[0] == 'a')
		{
			cin >> num2;
			cin >> s;
			cin >> s;
			if(mp[num1] /2 == mp[num2]/2)
				printf("T\n");
			else
				printf("F\n");
		}
		else
		{
			cin >> s;
			if(s[0] == 'a')
			{
				cin >> s;
				cin >> s;
				cin >> num2;
				if(mp[num1] /2 == mp[num2])
					printf("T\n");
				else 
					printf("F\n");
			}
			else 
			{
				cin >> s;
				if(s[0] == 'r')
				{
					if(mp[num1] == 1)
						printf("T\n");
					else 
						printf("F\n");
				}
				else 
				{
					cin >> s;
					cin >> num2;
					if(mp[num2] / 2 == mp[num1])
						printf("T\n");
					else 
						printf("F\n");
				}
			}
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值