1118:Lining Up(枚举)(已翻译)

描述

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

“我怎么才能解决这个问题呢?”飞行员说。的确,飞行员面临着一项艰巨的任务。她必须把包裹分散放在危险区域的特定地点。此外,飞机只能直线飞越该地区一次,她必须飞越尽可能多的点。所有的点都是通过一个二维空间中的整数坐标给出的。飞行员想知道在给定的集合中,所有点都在一条线上的最大点数。你能写一个程序来计算这个数字吗。你的程序必须高效!

输入
Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

输入由几个大小写组成,每个大小写的第一行是一个整数 N (1 < N < 700) ,然后跟随 N 对整数。每对整数由一个空格隔开,并以一个新行字符结束。输入以 N = 0结束。

输出
output one integer for each input case ,representing the largest number of points that all lie on one line.

输出一个整数为每个输入情况,表示最大数量的点,所有位于一行。

样例输入
5
1 1
2 2
3 3
9 10
10 11
0
样例输出
3
来源
East Central North America 1994


分析

直接暴力求解,用向量叉乘法判断共线提高精确度。


代码
#include<iostream>
#include<cstdio>
using namespace std;
typedef struct{
	int x,y;
}point;
int main()
{
	int i,j,k,n;
	while(cin>>n&&n)
	{
		point a[705];
		for(i=0;i<n;i++)
			scanf("%d%d",&a[i].x,&a[i].y);
		int ans=0;
		for(i=0;i<n;i++)		
			for(j=i+1;j<n;j++)
			{
				int max=2;
				for(k=j+1;k<n;k++)
					if((a[i].x-a[j].x)*(a[j].y-a[k].y)==(a[j].x-a[k].x)*(a[i].y-a[j].y))
						max++;
				if(ans<max) ans=max;
			}
		cout<<ans<<endl;
	}
	return 0;
}

给个赞和关注吧,欢迎评论 

  • 5
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值