POJ3660cow contest(floyd求传递闭包)

Cow Contest

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M(1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题意:有N头牛, 每一头牛都可被另外的牛打败,也可以打败其他的牛,如果A牛可打败B牛,且B牛可打败C牛,则说明A牛也可打败C牛,那么A牛和C牛的等级就确定了。让你确定总共有多少头牛的等级可以确定。

分析:利用Floyd求出传递闭包,如果有的牛之间可间接被打败,也就相当于放到图里边节点之间可间接到达,也可确定两者的等级。而每一头牛都是要么打败别的牛,要么被别的牛打败,而他打败的牛的数目,和打败他的牛的数目加起来刚好等于N-1,那么他的等级就确定了。而求传递闭包不需要考虑路径长短,只需要确定有没有路即可,如果有就设为1,没有就设为0。

Floyd求传递闭包算法核心:

  for(int k=1;k<=N;k++)
        for(int i=1;i<=N;i++)
        for(int j=1;j<=N;j++)
        edge[i][j]=edge[i][j]||(edge[i][k]&&edge[k][j]);

 核心代码:

#include <iostream>
#include <string.h>
#define MAX 105
using namespace std;

int main()
{
    int N,M;
    cin>>N>>M;
    int A,B;
    int edge[MAX][MAX];
    memset(edge,0,sizeof(edge));
    for(int i=0;i<M;i++)
    {
        cin>>A>>B;
        edge[A][B]=1;
    }
    for(int k=1;k<=N;k++)
        for(int i=1;i<=N;i++)
        for(int j=1;j<=N;j++)
        edge[i][j]=edge[i][j]||(edge[i][k]&&edge[k][j]);
    int cot,T=0;
    for(int i=1;i<=N;i++){
            cot=0;
            for(int j=1;j<=N;j++)
            {
                if(edge[i][j])
                    cot++;
                if(edge[j][i])
                    cot++;
            }
            if(cot==N-1)
                T++;
    }
    cout<<T<<endl;
    return 0;
}

 

内容概要:本文详细探讨了基于樽海鞘算法(SSA)优化的极限学习机(ELM)在回归预测任务中的应用,并与传统的BP神经网络、广义回归神经网络(GRNN)以及未优化的ELM进行了性能对比。首先介绍了ELM的基本原理,即通过随机生成输入层与隐藏层之间的连接权重及阈值,仅需计算输出权重即可快速完成训练。接着阐述了SSA的工作机制,利用樽海鞘群体觅食行为优化ELM的输入权重和隐藏层阈值,从而提高模型性能。随后分别给出了BP、GRNN、ELM和SSA-ELM的具体实现代码,并通过波士顿房价数据集和其他工业数据集验证了各模型的表现。结果显示,SSA-ELM在预测精度方面显著优于其他三种方法,尽管其训练时间较长,但在实际应用中仍具有明显优势。 适合人群:对机器学习尤其是回归预测感兴趣的科研人员和技术开发者,特别是那些希望深入了解ELM及其优化方法的人。 使用场景及目标:适用于需要高效、高精度回归预测的应用场景,如金融建模、工业数据分析等。主要目标是提供一种更为有效的回归预测解决方案,尤其是在处理大规模数据集时能够保持较高的预测精度。 其他说明:文中提供了详细的代码示例和性能对比图表,帮助读者更好地理解和复现实验结果。同时提醒使用者注意SSA参数的选择对模型性能的影响,建议进行参数敏感性分析以获得最佳效果。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值