POJ-3258-River Hopscotch (二分答案)

题目:http://poj.org/problem?id=3258

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, Lunits away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

分析:一条河里除了起点和终点,有n块石头,每块石头都和起点有一段距离,现在想移走M块石头,使得两块石头之间距离的最小值最大;最小值最大,最大值最小的问题我们可以用二分答案来解决;猜个值判断删除的点的个数是否等于M。

 //最小值最大化:
int Binarysearch(){
    int l = min_ans, r = max_ans;
    while(l < r)
    {
        int min = (l + r + 1)/2;           //+ 1 避免 r == l + 1时mid 一直等于1,陷入死循环。
        if(ok(mid)) {
            ans = mid;
            l = mid;
          }

        else r = mid - 1;
    }
    return ans;
}
//最大值最小化
int binarysearch()
{
    int l = min_ans,r = max_ans;
    while(l < r)
    {
        int mid = (l + r)/2;
        if(Ok(mid)){
                ans = mid;
                r = mid;
        }
        else l = mid + 1;
    }
    return ans;
}
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int maxn = 50010;
int dist[maxn];
int L,M,n;
bool solve(int x)//判断每一个猜测的距离是否合理
{
    int i = 0,cnt = 0;
    while(i <= n)
    {
        int j =  i + 1;
        while(j <= n && dist[j] - dist[i] < x)//删除两个距离小于x的点
        {
            cnt ++;
            if(cnt > M) return false;//如果点的个数大于要求值说明猜的值小了。
            j ++;
        }
        i = j;
    }
    return true;
}

int binarysearch()//二分答案
{
    int l = 0,r = L,ans;
    while(l < r)
    {
        int mid = (l + r + 1) / 2;
        if(solve(mid)){//如果slove返回1,就说明这个距离范围内的值偏小,或者相等。满足条件
            ans = mid;
            l = mid;
        }
        else r = mid - 1;
    }
    return ans;
}

int main()
{
    scanf("%d%d%d",&L,&n,&M);
    dist[0] = 0,dist[n+1] = L;
    for(int i = 1;i <= n;i ++)
    {
        scanf("%d",&dist[i]);
    }
    sort(dist,dist + n + 2);
    printf("%d\n",binarysearch());
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值