Median(poj-3579)-二分答案

题目:http://poj.org/problem?id=3579

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.

In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

分析;给你n个数di;计算出每两个数的差值,m=n*(n-1)/2;如果m是奇数,求出第(m+1)/2个最小的数,如果m是偶数,求出第m/2个最小的数。这个题利用二分答案,先将n个数排序,二分时取最大数和最小数的差值为上届,0为下届,不断枚举差值,之后判断这个差值下的元素对数会不会小于(m+1)/2,如果小于就说明枚举的数字大了,如果大于就说明枚举的小了。在枚举过程中,显然复杂度时O(n^2)但是我们可以利用upper_bound()函数,找到第一个大于di+x的位置,然后判断,就避免了一个一个的枚举。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int maxn = 100005;
int n,m;
int d[maxn],b[maxn];

bool fab(int a)
{
    return a < 0 ? a*(-1) : a;
}

bool check(int x)
{
    int cnt = 0;
    for(int i = 0;i < n;i ++)
        {
            int t = upper_bound(d,d + n,d[i] + x) - d;
            cnt += (t - i -1);
        }
    m = n*(n - 1) / 2;
    m = (m + 1) / 2;
    if(cnt >= m) return true;
    else return false;
}

int binarysearch(int left,int right)
{
    int l = left,r = right;
    int ans;
    int mid;
    while(l <= r)
    {
        mid = (l + r)/2;
        if(check(mid))
        {
            ans = mid;
            r = mid - 1;
        }
        else {
            l = mid + 1;
        }
    }
    return ans;
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i = 0;i < n;i ++)
        {
            scanf("%d",&d[i]);
        }
        sort(d,d + n);
        int left  = 0,right = d[n-1] - d[0];
        printf("%d\n",binarysearch(left,right));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值