工作中一些常见错误总结(不断总结)

记录一些工作中遇到的错误,会一致更新,遇到新的错误就会总结上来,给自己提供个便利。省的以后遇到同样的bug.

1.tomcat version 6.0 only supports j2ee 1.2, 1.3, 1.4, and java ee 5 web modul

这个错误是使用eclipse配置的tomcat加载工程时报的,因为tomcat的版本较低,而工程中配置的版本较高造成的。具体的原理不是很清楚。

解决方案是:project的.setting folder下面,有个名为org.eclipse.wst.common.project.facet.core.xml的文件,里面配置有各种版本信息。 修改这个配置文件就行了。

将<installed facet="jst.web" version="3.0"/> 只要将version="3.0"改成version="2.5",然后重启eclipse即可!!!

或者下载高版本的Tomcat (Tomcat  7.0以上)。

具体请参考:http://hi.baidu.com/yolanda441/item/f217baf9161b8fc10dd1c854 和http://blog.csdn.net/java85140031/article/details/12944295


jQuery Mobile页面跳转后未加载外部JS原因分析及解决

原因:在使用jQuery Mobile进行Web开发中,当页面跳转时(pageA => pageB),在pageB中引用的JS并未成功运行。因为,JQM并为将整个页面加载到当前的dom中,仅将data-role="page"元素加入当前的dom中。

遇到的问题是 从一个使用Jquery Mobile开发的页面的a标签跳转到另外一个页面的时候,页面没有进行加载,但是刷新之后 页面的样式JS数据全部都正常显示。

解决: 将两个页面均使用JQuery Mobile 开发 或者全都摒弃掉JQuery Mobile 可以解决



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值