AcWing.847-图中点的层次
题目描述
给定一个 n个点 m 条边的有向图,图中可能存在重边和自环。
所有边的长度都是 1,点的编号为 1∼n。
请你求出 1 号点到 n 号点的最短距离,如果从 1 号点无法走到 n号点,输出 −1。
输入格式
第一行包含两个整数 n和 m。
接下来 m 行,每行包含两个整数 a 和 b,表示存在一条从 a 走到 b 的长度为 1 的边。
输出格式
输出一个整数,表示 1 号点到 n 号点的最短距离。
数据范围
1≤n,m≤105
输入样例:
4 5
1 2
2 3
3 4
1 3
1 4
输出样例:
1
题解
package acWing847;
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;
import java.util.LinkedList;
import java.util.Queue;
public class Main {
static int n,m;
static int N = 100010;
static int h[] = new int[N],e[] = new int[N],ne[] = new int[N],idx;
static int d[] = new int[N];
static void add(int a,int b) {
e[idx] =b;
ne[idx] = h[a];
h[a] = idx++;
}
static int bfs() {
Arrays.fill(d, -1);
Queue<Integer> q = new LinkedList<>();
d[1] = 0;
q.add(1);
while(!q.isEmpty()) {
int t = q.poll();
for(int i=h[t];i!=-1;i=ne[i]) {
int j = e[i];
if(d[j]==-1) {
d[j] = d[t]+1;
q.add(j);
}
}
}
return d[n];
}
public static void main(String[] args) throws IOException {
BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
String str[] = bf.readLine().split(" ");
Arrays.fill(h,-1);
n = Integer.parseInt(str[0]);m = Integer.parseInt(str[1]);
for(int i=0;i<m;i++) {
str= bf.readLine().split(" ");
int a =Integer.parseInt(str[0]),b = Integer.parseInt(str[1]);
add(a,b);
}
System.out.println(bfs());
}
}