微软2014在线编程一小时活动第一题



题目1 : Arithmetic Expression

时间限制:2000ms

单点时限:200ms

内存限制:256MB


描述

Given N arithmetic expressions, can you tell whose result is closest to 9?

输入

Line 1: N (1 <= N <= 50000).
Line 2..N+1: Each line contains an expression in the format of "a op b" where a, b are

integers (-10000 <= a, b <= 10000) and op is one of addition (+), subtraction (-),

multiplication (*) and division (/). There is no "divided by zero" expression.


输出

The index of expression whose result is closest to 9. If there are more than one such

expressions, output the smallest index.


样例输入
4
901 / 100
3 * 3
2 + 6
8 - -1

样例输出
2

#include <iostream>
using std::cin;
using std::cout;
using std::endl;

float opFun(int a,int b,char op)
{
	float c=0;
	float a1 = (float)a;
	float b1 = (float)b;
	switch(op)
	{
		case '+':
			c=a1+b1;break;
		case '-':
			c=a1-b1;break;
		case '*':
			c=a1*b1;break;
		case '/':
			c=a1/b1;break;
		default:
			break;
	}
	return c;
}

int main(void)
{
	int a,b,N,flag,i=0;
	float value=0,c,d1,d2;
	char op;
	cin>>N;
	cin>>a>>op>>b;
	value = opFun(a,b,op);
	i++;
	flag = i;

	while(++i<=N)
	{
		cin>>a>>op>>b;
		c = opFun(a,b,op);

		d1 = value-9;
		d2 = c-9;
		d1 = d1<0?-d1:d1;
		d2 = d2<0?-d2:d2;

		if(d1>d2)
		{
			value=c;
			flag = i;
		}
	}
	cout<<flag<<endl;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值