pat 1020. Tree Traversals (25)

12 篇文章 0 订阅

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
#define ms(x,y) memset(x,y,sizeof(x))
#define rep(i,j,k) for(i=j;i<=k;i++)
#define inone(i) scanf("%d",&i)
const int maxn = 30 + 10;
int v[maxn], l[maxn], r[maxn], n, pst[maxn], ino[maxn], tot, flag;
void build(int &root, int pl, int pr, int il, int ir)
{
	if (pl > pr || il > ir) return;
	int i;
	root = tot++;
	v[root] = pst[pr];
	rep(i, il, ir) if (ino[i] == pst[pr]) break;
	build(l[root], pl, pl + i - il - 1, il, i-1);
	build(r[root], pl + i - il, pr-1, i + 1, ir);
}

void levelT(int root)
{
	queue<int> q;
	q.push(root);
	while (!q.empty()) 
	{

		int nd = q.front(); q.pop();
		printf("%s%d", flag ? " " : "", v[nd]);
		flag = 1;
		if (l[nd] != -1) q.push(l[nd]);
		if (r[nd] != -1) q.push(r[nd]);
	}
	puts("");
}

int main()
{
	inone(n);
	int i, root;
	rep(i, 1, n) inone(pst[i]);
	rep(i, 1, n) inone(ino[i]);
	ms(l, -1); ms(r, -1);
	build(root, 1, n, 1, n);
	levelT(root);
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值