数据结构实验之二叉树五:层序遍历

数据结构实验之二叉树五:层序遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

输入

  输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是 一个长度小于50个字符的字符串。

输出

  输出二叉树的层次遍历序列。

示例输入

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

示例输出

abcdefg
xnuli

提示

 

来源

 xam

示例程序

 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char a[100];
int l1;
struct node
{
int data;
struct node *lchild,*rchild;
};
struct node *creat()
{
struct node  *root;
char c;
c=a[l1++];
if(c==',')
    return NULL;
else
{
    root=(struct node *)malloc(sizeof(struct node));
root->data=c;
root->lchild=creat();
root->rchild=creat();

}
return root;
}
void cengci(struct node *root)
{
int out=0,in=0;
struct node *q[100];
q[in++]=root;
while(in>out)
{
if(q[out])
{
printf("%c",q[out]->data);
q[in++]=q[out]->lchild;
q[in++]=q[out]->rchild;
}
out++;
}
}
int main()
{
int i,j,n,m,k,t;
struct node *root;
while(scanf("%d",&n)!=EOF)
{
    for(i=0;i<n;i++)
    {
        scanf("%s",a);
        l1=0;
    root=(struct node *)malloc(sizeof(struct node));
root=creat();
cengci(root);
printf("\n");
}
}
return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值