Catch That Cow

Catch That Cow

Time Limit: 2000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入

Line 1: Two space-separated integers: N and K

输出

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

示例输入

5 17

示例输出

4

提示

poj3278  有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。  
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

来源

广度优先搜索练习

示例程序


#include<stdio.h>  
#include<string.h>  
#include<queue>  
using namespace std;  
#define Max 100010  
queue<int> que;  
int d[Max],m;  
int check(int x)  
{  
if(x>=0&&x<=m+2&&d[x]==-1)  
return 1;  
else  
return 0;  
}  
int BSF(int x)  
{  
que.push(x);  
d[x]=0;  
while(!que.empty())  
{  
x=que.front();  
que.pop();  
if(x==m)  
break;  
if(check(x+1))  
{  
d[x+1]=d[x]+1;  
que.push(x+1);  
}  
if(check(x-1))  
{  
d[x-1]=d[x]+1;  
que.push(x-1);  
}  
if(check(2*x))  
{  
d[2*x]=d[x]+1;  
que.push(2*x);  
}  
}  
return d[m];  
}  
int main()  
{  
int i,j,n,t,k;  
while(scanf("%d %d",&n,&m)!=EOF)  
{  
if(n>=m)  
{  
printf("%d\n",n-m);  
continue;  
}  
memset(d,-1,sizeof(d));  
while(!que.empty())  
que.pop();  
k=BSF(n);  
printf("%d\n",k);  
}  
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值