IBM Minus One

IBM Minus One

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story ends, in case you want to read the book for yourself :-)  

After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.  

Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

输入

The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

输出

For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing 'Z' by 'A'.  

Print a blank line after each test case.

示例输入

2
HAL
SWERC

示例输出

String #1
IBM

String #2
TXFSD

提示


来源

面向对数据结构和算法不太懂的同学

示例程序

 
#include<stdio.h>  
int main()  
{  
    int i,j,n;  
    char a[50];  
    scanf("%d\n",&n);  
    for(i=1;i<=n;i++)  
    {  
        gets(a);  
        printf("String #%d\n",i);  
        for(j=0;a[j]!='\0';j++)  
        {  
            if(a[j]=='Z')  
                printf("%c",65);  
                else  
            printf("%c",a[j]+1);  
        }  
        printf("\n\n");  
    }  
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值