Word

Word

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

 Tom is very upset that many people on the internet mix uppercase and lowercase letters in one word. That's why he decided to invent an extension for his favorite browser that would change the letters' register in every word so that it either only consisted of lowercase letters or, vice versa, only of uppercase ones. At that as little as possible letters should be changed in the word. For example, the word HoUse must be replaced with house, and the word ViP — with VIP. If a word contains an equal number of uppercase and lowercase letters, you should replace all the letters with lowercase ones. For example, maTRIx should be replaced by matrix. Your task is to use the given method on one given word.

输入

 The first line of input contains an integers T, indicating T test case will follow.Each of the next T lines contains a word s — it consists of uppercase and lowercase Latin letters and possesses the length from 1 to 100.

输出

 Print the corrected word s. If the given word s has strictly more uppercase letters, make the word written in the uppercase register, otherwise - in the lowercase one.

示例输入

3
HoUse
ViP
maTRIx

示例输出

house
VIP
matrix

提示

 

来源

 

示例程序

 
#include<stdio.h>  
#include<string.h>  
#include<ctype.h>  
char a[10000];  
int main()  
{  
    int i,j,n,m,t,k;  
    scanf("%d",&n);  
    for(i=0;i<n;i++)  
    {  
        k=0;  
        t=0;  
        scanf("%s",a);  
        m=strlen(a);  
        for(j=0;j<m;j++)  
        {  
            if(islower(a[j]))  
                k++;  
            if(isupper(a[j]))  
                t++;  
        }  
        if(k>=t)  
            for(j=0;j<m;j++)  
                a[j]=tolower(a[j]);  
            else  
                for(j=0;j<m;j++)  
                    a[j]=toupper(a[j]);  
        printf("%s\n",a);  
    }  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值