A Simple Task

A Simple Task

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.
 
Example
 
For n = 24, o = 3 and p = 3.

Task
 
Write a program which for each data set:

reads a positive integer n,
 
computes the odd integer o and the nonnegative integer p such that n = o2^p,

writes the result.

输入

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.
 
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

输出

The output should consists of exactly d lines, one line for each data set.
 
Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.

示例输入

1
24

示例输出

3 3

提示

zoj1382有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。

来源

面向对数据结构和算法不太懂的同学
#include<stdio.h>  
#include<math.h>  
int main()  
{  
int i,j,n,m,k,t;  
scanf("%d",&t);  
while(t--)  
{  
scanf("%d",&n);  
for(i=1;i<=n;i+=2)  
for(j=0;i*(pow(2,j))<=n;j++)  
if(i*(pow(2,j))==n)  
printf("%d %d\n",i,j);  
}  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值