DNA repair

DNA repair

Time Limit: 2000ms   Memory limit: 32768K  有疑问?点这里^_^

题目描述

Biologists finally invent techniques of repairing DNA that contains segments causing kinds of inherited diseases. For the sake of simplicity, a DNA is represented as a string containing characters 'A', 'G' , 'C' and 'T'. The repairing techniques are simply to change some characters to eliminate all segments causing diseases. For example, we can repair a DNA "AAGCAG" to "AGGCAC" to eliminate the initial causing disease segments "AAG", "AGC" and "CAG" by changing two characters. Note that the repaired DNA can still contain only characters 'A', 'G', 'C' and 'T'.

You are to help the biologists to repair a DNA by changing least number of characters.

输入

The input consists of multiple test cases. Each test case starts with a line containing one integers N (1 ≤ N ≤ 50), which is the number of DNA segments causing inherited diseases. The following N lines gives N non-empty strings of length not greater than 20 containing only characters in "AGCT", which are the DNA segments causing inherited disease. The last line of the test case is a non-empty string of length not greater than 1000 containing only characters in "AGCT", which is the DNA to be repaired.

The last test case is followed by a line containing one zeros.

输出

For each test case, print a line containing the test case number( beginning with 1) followed by the number of characters which need to be changed. If it's impossible to repair the given DNA, print -1.

示例输入

2
AAA
AAG
AAAG    
2
A
TG
TGAATG
4
A
G
C
T
AGT
0

示例输出

Case 1: 1
Case 2: 4
Case 3: -1

提示

hdoj2457 有链接提示的题目请先去链接处提交程序,AC后提交到SDUTOJ中,以便查询存档。

来源

2008 Asia Hefei Regional Contest Online by USTC

示例程序

 
#include<iostream>    
    #include<cstdio>    
    #include<cstring>    
    #include<cmath>    
    #include<algorithm>    
    #define N 100005    
    #define MOD 100000    
    #define inf 1<<29    
    #define LL long long    
    using namespace std;    
    struct Trie{    
        Trie *next[4];    
        Trie *fail;    
        int kind,isword;    
    };    
    Trie *que[N],s[N];    
    int idx;    
    int id(char ch){    
        if(ch=='A') return 0;    
        else if(ch=='T') return 1;    
        else if(ch=='C') return 2;    
        return 3;    
    }    
    Trie *NewNode(){    
        Trie *tmp=&s[idx];    
        for(int i=0;i<4;i++) tmp->next[i]=NULL;    
        tmp->isword=0;    
        tmp->kind=idx++;    
        tmp->fail=NULL;    
        return tmp;    
    }    
    void Insert(Trie *root,char *s,int len){    
        Trie *p=root;    
        for(int i=0;i<len;i++){    
            if(p->next[id(s[i])]==NULL)    
                p->next[id(s[i])]=NewNode();    
            p=p->next[id(s[i])];    
        }    
        p->isword=1;    
    }    
    void Bulid_Fail(Trie *root){    
        int head=0,tail=0;    
        que[tail++]=root;    
        root->fail=NULL;    
        while(head<tail){    
            Trie *tmp=que[head++];    
            for(int i=0;i<4;i++){    
                if(tmp->next[i]){    
                    if(tmp==root) tmp->next[i]->fail=root;    
                    else{    
                        Trie *p=tmp->fail;    
                        while(p!=NULL){    
                            if(p->next[i]){    
                               tmp->next[i]->fail=p->next[i];    
                               break;    
                            }    
                            p=p->fail;    
                        }    
                        if(p==NULL) tmp->next[i]->fail=root;    
                    }    
                    if(tmp->next[i]->fail->isword) tmp->next[i]->isword=1;    
                    que[tail++]=tmp->next[i];    
                }    
                else if(tmp==root) tmp->next[i]=root;    
                else tmp->next[i]=tmp->fail->next[i];    
            }    
        }    
    }    
    int dp[1005][2005];    
    int slove(char *str,int len){    
        for(int i=0;i<=len;i++) for(int j=0;j<idx;j++) dp[i][j]=inf;    
        dp[0][0]=0;    
        for(int i=1;i<=len;i++){    
            for(int j=0;j<idx;j++){    
                if(s[j].isword) continue;    
                if(dp[i-1][j]==inf) continue;    
                for(int k=0;k<4;k++){    
                    int r=s[j].next[k]->kind;    
                    if(s[r].isword) continue;    
                    dp[i][r]=min(dp[i][r],dp[i-1][j]+(id(str[i-1])!=k));    
                }    
            }    
        }    
        int ans=inf;    
        for(int i=0;i<idx;i++) ans=min(ans,dp[len][i]);    
        return ans==inf?-1:ans;    
    }    
    char str[1005];    
    int main(){    
        int n,cas=0;    
        while(scanf("%d",&n)!=EOF&&n){    
            idx=0;    
            Trie *root=NewNode();    
            for(int i=0;i<n;i++){    
                scanf("%s",str);    
                Insert(root,str,strlen(str));    
            }    
            Bulid_Fail(root);    
            scanf("%s",str);    
            printf("Case %d: %d\n",++cas,slove(str,strlen(str)));    
        }    
        return 0;    
    }  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值