Beautiful Year

Beautiful Year

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
       It seems like the year of 2013 came only yesterday. Do you know a curious fact? The year of 2013 is the first year after the old 1987 with only distinct digits.
      Given a year number, find the minimum year number which is strictly larger than the given one and has only distinct digits.
Input
 There are multiple test cases.
Each test case contains a single line contains integer y (1000 ≤ y ≤ 9000) — the year number.
Output
For each test case:
Print a single integer — the minimum year number that is strictly larger than y and all it's digits are distinct.
It is guaranteed that the answer exists.
Example Input
1987
2013
Example Output
2013
2014
Hint
 
Author
qinchuan


#include<stdio.h>
int main()
{
    int n,m,k,i,j,a,b,c,d;
    while(scanf("%d",&n)!=EOF)
        {
            for(i=n+1;;i++)
            {
              a=i%10;
              b=(i/10)%10;
              c=(i/100)%10;
              d=(i/1000)%10;
              if(a!=b&&a!=c&&a!=d&&b!=c&&b!=d&&c!=d)
              {
                  printf("%d\n",i);
                  break;
              }
            }

        }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值