1004. Counting Leaves (30)
Input
Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.
Sample Input2 1 01 1 02Sample Output
0 1
题目大意:
家族层次结构通常由系谱树表示。你的任务是计算那些没有孩子的家庭成员。
输入
每个输入文件包含一个测试用例。每一个用例都以一行0<N<100的数开始,N代表树节点的个数,M(<N)代表非叶子节点的个数。接下来是M行,每一行的格式为:
ID K ID[1] ID[2] ... ID[K]
ID是一个两位数表示给定的非叶子节点,K代表他的孩子的个数,然后是一个两位数字ID的子序列。为了简单起见,让我们将根ID固定为01
输出
对于每个测试用例,你应该从根节点计算每一层没有孩子节点的家庭成员的数量。数字必须打一在一行中,用空格隔开,在每一行的末尾绝对不能有多余的空格。
案例表示一个只有俩个节点的树,其中01是根节点,02是他唯一的子节点。因此在根节点01那一层上,有0个叶节点;在下一层有一个叶节点。因此我们应该在一行上输出“0 1”。
代码:
#include<bits/stdc++.h>
using namespace std;
int mapt[101][101],n;
void level_traversal()
{
queue<int> que;
int i,node,j,p,countt=0;
que.push(1);
p=1;
int l=0;
while(!que.empty())
{
node=que.front();
que.pop();
int flag=0;
for(i=1;i<=n;i++)
{
if(mapt[node][i]==1)
{
que.push(i);
flag=1;
}
}
if(flag==0)
countt++;
if(p==node)
{
p=que.back();
if(l==0)
{
printf("%d",countt);
l=1;
}
else
printf(" %d",countt);
countt=0;
}
}
}
int main()
{
int i,j,m,k,t,p;
scanf("%d %d",&n,&m);
for(i=0;i<m;i++)
{
scanf("%d %d",&k,&t);
for(j=0;j<t;j++)
{
scanf("%d",&p);
mapt[k][p]=1;
}
}
level_traversal();
return 0;
}