1017. Queueing at Bank (25)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

题目大意:

假设一家银行有K个窗口提供服务。窗前的黄线将等候区分成两个部分。所有的顾客必须在黄线之外排队等候,直到轮到他/她服务,并且还有窗口可用。假设一个客户不能占用窗口超过一个小时。
现在给出每个用户的到达时间T和业务处理时间P,你的任务是计算出所有用户的平均等待时间。
输入规格:
每个输入文件包含一个测试用例。对于每个测试用例,首先包含两个数字:N(<=10000)-客户的总数,K(<=100)-窗口的数量。接下来是N行,每一行包含两个时间:HH:MM:SS -到达时间,P-用户的业务办理时间。HH的范围是[00,23],MM和SS的范围是[00,59],假设没有两个用户到达的时间相同。
注意银行的开放时间是早晨8:00到下午17:00。早于8:00到达的必须等到8:00,对于那些晚来的(17:01或之后)将不会给与服务也不会计入平均数。
输出规格:
对于每个测试用例,打印出所有用户的平均等待时间,以分钟的形式打印并保留一位小数。

代码:

#include<stdio.h>
#include<stdlib.h>
struct node
{
  int  time;
  int servicetime;
  int wait;
}customer[10001];
int waittime[101];
int cmp(const void *a,const void *b)
{
    return (*(node *)a).time>(*(node *)b).time?1:-1;
}
int main()
{
    int i,j,n,m,k,t,hour,minute,second,stime,Min,index,sum;
    scanf("%d %d",&n,&k);
    for(i=0;i<k;i++)
    {
        waittime[i]=28800;
    }
    for(i=0,t=0;i<n;i++)
    {
        scanf("%d%*c%d%*c%d%*c%d",&hour,&minute,&second,&stime);
        if(hour>17)
        {
            continue;
        }
        else if(hour==17&&(minute!=0||second!=0))
                {
                    continue;
                }
        customer[t].time=hour*60*60+minute*60+second;
        customer[t].servicetime=stime;
        t++;
    }
    qsort(customer,t,sizeof(customer[0]),cmp);
        for(i=0;i<t;i++)
        {
            Min=waittime[0];
            index=0;
           for(j=1;j<k;j++)
           {
               if(Min>waittime[j])
               {
                   Min=waittime[j];
                   index=j;
               }
           }
           if(customer[i].time<Min)
           {
               customer[i].wait=Min-customer[i].time;
               waittime[index]=Min+customer[i].servicetime*60;
           }
           else
           {
              customer[i].wait=0;
              waittime[index]=customer[i].time+customer[i].servicetime*60;
           }
        }
        sum=0;
        for(i=0;i<t;i++)
        {
            sum+=customer[i].wait;
        }
        printf("%.1lf\n",sum*1.0/t/60);
    return 0;
}

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值