1027. Colors in Mars (20)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456

题目大意:

火星上的人们用与地球人相似的方式来表示他们电脑上的颜色。也就是说,一个颜色用一个6位数表示,前两位表示红色,中间两位表示绿色,最后两位表示蓝色。唯一的区别是他们是用13(0-9和A-C)进制而不是16进制表示。现在给定三个十进制数(每个数在0到168之间),你的任务是输出他们火星上的RGB值。
输入
每一个测试文件包含一个测试用例,测试用例在一行上包含三个十进制颜色值。
输出:
对于每个测试用例你应该以:首先输出“#”,然后输出6位英文必须是大写如果单个颜色只有一位数长必须在他的左面打印“0”的数字的格式输出火星人的RGB值。

代码:

#include<stdio.h>
void change(int x)
{
    int z=x/13;
    if(z==10)
            printf("A");
        else if(z==11)
            printf("B");
        else if(z==12)
            printf("C");
        else
            printf("%d",z);
    int y=x%13;
    if(y==10)
            printf("A");
        else if(y==11)
            printf("B");
        else if(y==12)
            printf("C");
        else
            printf("%d",y);
}
int main()
{
    int i,j,n,m,k,t;
    scanf("%d %d %d",&n,&m,&k);
    printf("#");
    change(n);
    change(m);
    change(k);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值